summaryrefslogtreecommitdiffstats
path: root/brother-dcp9010cn
diff options
context:
space:
mode:
Diffstat (limited to 'brother-dcp9010cn')
-rw-r--r--brother-dcp9010cn/PKGBUILD44
-rwxr-xr-xbrother-dcp9010cn/brlpdwrapperdcp9010cn138
-rw-r--r--brother-dcp9010cn/brother-dcp9010cn-1.1.1-4-i686-build.log0
-rw-r--r--brother-dcp9010cn/dcp9010cncupswrapper-1.1.1-4.i386.debbin12426 -> 0 bytes
-rw-r--r--brother-dcp9010cn/dcp9010cnlpr-1.1.1-4.i386.debbin617502 -> 0 bytes
5 files changed, 0 insertions, 182 deletions
diff --git a/brother-dcp9010cn/PKGBUILD b/brother-dcp9010cn/PKGBUILD
deleted file mode 100644
index ef5e351..0000000
--- a/brother-dcp9010cn/PKGBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# Contributor: Pavel Benak <pavel.benak@uhk.cz>
-
-pkgname=brother-dcp9010cn
-pkgver=1.1.1
-pkgrel=4
-pkgdesc="Brother cups and lpd driver for DCP-9010CN"
-arch=('i686' 'x86_64')
-url="http://solutions.brother.com/linux/en_us/index.html"
-license=('custom')mm
-if [ "$(uname -m)" = "x86_64" ]
-then
- depends=('lib32-glibc' 'psutils')
-else
- depends=('psutils')
-fi
-noextract=(DCP7010.ppd.gz)
-
-source=(
-http://www.brother.com/pub/bsc/linux/dlf/dcp9010cncupswrapper-$pkgver-$pkgrel.i386.deb
-http://www.brother.com/pub/bsc/linux/dlf/dcp9010cnlpr-$pkgver-$pkgrel.i386.deb
-brlpdwrapperdcp9010cn
-)
-
-md5sums=('f8fbdc819c5ed1d54fdfe0da24e2939d'
- '6b24a542b9d2f755d43cf0e6c91101ad'
- '3ba6c4dd55eb15f918741f4ad102570f')
-
-build()
-{
- mkdir -p $startdir/src/unpack || return 1
- for i in $startdir/src/*.deb
- do
- cd $startdir/src/unpack
- ar -x $i || return 1
- cd $startdir/pkg
- bsdtar xf $startdir/src/unpack/data.tar.gz || return 1
- done
-
- cd $startdir/src
- install -d -m755 $startdir/pkg/usr/share/cups/model || return 1
- install -d -m755 $startdir/pkg/usr/lib/cups/filter || return 1
- install -D -m644 $startdir/pkg/usr/local/Brother/Printer/dcp9010cn/cupswrapper/dcp9010cn.ppd $startdir/pkg/usr/share/cups/model || return 1
- install -D -m755 brlpdwrapperdcp9010cn $startdir/pkg/usr/lib/cups/filter || return 1
-}
diff --git a/brother-dcp9010cn/brlpdwrapperdcp9010cn b/brother-dcp9010cn/brlpdwrapperdcp9010cn
deleted file mode 100755
index 960fb89..0000000
--- a/brother-dcp9010cn/brlpdwrapperdcp9010cn
+++ /dev/null
@@ -1,138 +0,0 @@
-#! /bin/sh
-#
-# Copyright (C) 2005 Brother. Industries, Ltd.
-# Ver1.10
-
-# This program is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by the Free
-# Software Foundation; either version 2 of the License, or (at your option)
-# any later version.
-#
-# This program is distributed in the hope that it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
-# more details.
-#
-# You should have received a copy of the GNU General Public License along with
-# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
-# Place, Suite 330, Boston, MA 02111-1307 USA
-#
-
-LOGFILE="/dev/null"
-LOGLEVEL="1"
-LOGCLEVEL="7"
-DEBUG=0
-NUPENABLE=1
-LOG_LATESTONLY=1
-errorcode=0
-
-if [ $DEBUG != 0 ]; then
- LOGFILE=/tmp/br_cupsfilter_debug_log
-fi
-
-PPDC=`printenv | grep "PPD="`
-PPDC=`echo $PPDC | sed -e 's/PPD=//'`
-
-if [ "$PPDC" = "" ]; then
- PPDC="/usr/share/cups/model/brdcp9010cn.ppd"
-fi
-
-
-if [ $LOGFILE != "/dev/null" ]; then
- if [ $LOG_LATESTONLY == "1" ]; then
- rm -f $LOGFILE
- date >$LOGFILE
- else
- if [ -e $LOGFILE ]; then
- date >>$LOGFILE
- else
- date >$LOGFILE
- fi
- fi
- echo "arg0 = $0" >>$LOGFILE
- echo "arg1 = $1" >>$LOGFILE
- echo "arg2 = $2" >>$LOGFILE
- echo "arg3 = $3" >>$LOGFILE
- echo "arg4 = $4" >>$LOGFILE
- echo "arg5 = $5" >>$LOGFILE
- echo "arg6 = $6" >>$LOGFILE
- echo "PPD = $PPD" >>$LOGFILE
-fi
-
-INPUT_TEMP_PS=`mktemp /tmp/br_input_ps.XXXXXX`
-
-nup="cat"
-if [ "" != '' ] && [ $NUPENABLE != 0 ]; then
-
- if [ "" != '' ]; then
- nup="psnup -64"
- elif [ "" != '' ]; then
- nup="psnup -32"
- elif [ "" != '' ]; then
- nup="psnup -25"
- elif [ "" != '' ]; then
- nup="psnup -16"
- elif [ "" != '' ]; then
- nup="psnup -8"
- elif [ "" != '' ]; then
- nup="psnup -6"
- elif [ "" != '' ]; then
- nup="psnup -4"
- elif [ "" != '' ]; then
- nup="psnup -2"
- elif [ "" != '' ]; then
- nup="cat"
- fi
- echo "NUP=$nup" >>$LOGFILE
- if [ -e /usr/bin/psnup ]; then
- if [ $# -ge 7 ]; then
- cat $6 | $nup > $INPUT_TEMP_PS
- else
- cat | $nup > $INPUT_TEMP_PS
- fi
- else
- if [ $# -ge 7 ]; then
- cp $6 $INPUT_TEMP_PS
- else
- cat > $INPUT_TEMP_PS
- fi
- fi
-else
- if [ $# -ge 7 ]; then
- cp $6 $INPUT_TEMP_PS
- else
- cat > $INPUT_TEMP_PS
- fi
-fi
-if [ -e "/usr/local/Brother/Printer/dcp9010cn/lpd/filterdcp9010cn" ]; then
- :
-else
- echo "ERROR: /usr/local/Brother/Printer/dcp9010cn/lpd/filterdcp9010cn does not exist" >>$LOGFILE
- errorcode=30
- exit
-fi
-
-CUPSOPTION=`echo "$5 Copies=1" | sed -e 's/BrMirror=OFF/MirrorPrint=OFF/' -e 's/BrMirror=ON/MirrorPrint=ON/' -e 's/BrChain/Chain/' -e 's/BrBrightness/Brightness/' -e 's/BrContrast/Contrast/' -e 's/BrHalfCut/HalfCut/' -e 's/BrAutoTapeCut/AutoCut/' -e 's/BrHalftonePattern/Halftone/' -e 's/Binary/Binary/' -e 's/Dither/Dither/' -e 's/ErrorDiffusion/ErrorDiffusion/' -e 's/BrSheets/Sheets/' -e 's/multiple-document-handling/Collate/' -e 's/separate-documents-collated-copies/ON/' -e 's/separate-documents-uncollated-copies/OFF/'`
-if [ -e "/usr/local/Brother/Printer/dcp9010cn/cupswrapper/brcupsconfpt1" ]; then
- if [ $DEBUG = 0 ]; then
- /usr/local/Brother/Printer/dcp9010cn/cupswrapper/brcupsconfpt1 DCP9010CN $PPDC 0 "$CUPSOPTION" "dcp9010cn">> /dev/null
- else
- /usr/local/Brother/Printer/dcp9010cn/cupswrapper/brcupsconfpt1 DCP9010CN $PPDC $LOGCLEVEL "$CUPSOPTION" "dcp9010cn">>$LOGFILE
- fi
-fi
-
-if [ $DEBUG -lt 10 ]; then
- cat $INPUT_TEMP_PS | /usr/local/Brother/Printer/dcp9010cn/lpd/filterdcp9010cn "$$" "CUPS" "USB"
-
- if [ $LOGLEVEL -gt 2 ]; then
- if [ $LOGFILE != "/dev/null" ]; then
- echo "" >>$LOGFILE
- echo " ------PostScript Data-------" >>$LOGFILE
- cat $INPUT_TEMP_PS >>$LOGFILE
- fi
- fi
-fi
-rm -f $INPUT_TEMP_PS
-
-exit
-
diff --git a/brother-dcp9010cn/brother-dcp9010cn-1.1.1-4-i686-build.log b/brother-dcp9010cn/brother-dcp9010cn-1.1.1-4-i686-build.log
deleted file mode 100644
index e69de29..0000000
--- a/brother-dcp9010cn/brother-dcp9010cn-1.1.1-4-i686-build.log
+++ /dev/null
diff --git a/brother-dcp9010cn/dcp9010cncupswrapper-1.1.1-4.i386.deb b/brother-dcp9010cn/dcp9010cncupswrapper-1.1.1-4.i386.deb
deleted file mode 100644
index 08b2772..0000000
--- a/brother-dcp9010cn/dcp9010cncupswrapper-1.1.1-4.i386.deb
+++ /dev/null
Binary files differ
diff --git a/brother-dcp9010cn/dcp9010cnlpr-1.1.1-4.i386.deb b/brother-dcp9010cn/dcp9010cnlpr-1.1.1-4.i386.deb
deleted file mode 100644
index 2454cf3..0000000
--- a/brother-dcp9010cn/dcp9010cnlpr-1.1.1-4.i386.deb
+++ /dev/null
Binary files differ