summaryrefslogtreecommitdiffstats
path: root/btnx
diff options
context:
space:
mode:
Diffstat (limited to 'btnx')
-rw-r--r--btnx/PKGBUILD34
-rwxr-xr-xbtnx/btnx52
-rw-r--r--btnx/makefile.patch11
3 files changed, 0 insertions, 97 deletions
diff --git a/btnx/PKGBUILD b/btnx/PKGBUILD
deleted file mode 100644
index c54f211..0000000
--- a/btnx/PKGBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Contributor: Florian Pritz <f-p@gmx.at>
-# Contributor: Graziano Giuliani <graziano.giuliani@poste.it>
-
-pkgname=btnx
-pkgver=0.4.11
-pkgrel=3
-pkgdesc="Button Extension- a GNU/GPL mouse tool for GNU/Linux"
-arch=('i686' 'x86_64')
-url="http://www.ollisalonen.com/btnx/"
-license=('GPL')
-groups=(daemons)
-depends=('btnx-config' 'libdaemon')
-options=('!libtool' '!emptydirs')
-source=(http://www.ollisalonen.com/btnx/${pkgname}-${pkgver}.tar.gz
- btnx)
-
-build() {
- cd ${srcdir}/${pkgname}-${pkgver}
-
- ./configure || return 1
- make || return 1
-
- mkdir -p ${pkgdir}/etc/btnx
-
- install -Dm 755 src/btnx ${pkgdir}/usr/sbin/btnx || return 1
- install -Dm 644 data/events -p ${pkgdir}/etc/btnx/events || return 1
- install -Dm 755 ${srcdir}/btnx ${pkgdir}/etc/rc.d/btnx || return 1
-}
-
-# vim:set ts=2 sw=2 et:
-md5sums=('8216a84f8fe873ddc97afbfccfc2d254'
- '4c9ff4950bc766002e34e53bffc61521')
-sha256sums=('350fd6453f5ac85019a2a5e9feb926ceccf7d17e2243ba47ede0a165890fe82d'
- 'ff3030a22b7e054cd89b38632b8ef91ad0b2f777ba42bc4a2421f534046cdc02')
diff --git a/btnx/btnx b/btnx/btnx
deleted file mode 100755
index 2c3534c..0000000
--- a/btnx/btnx
+++ /dev/null
@@ -1,52 +0,0 @@
-#! /bin/bash
-
-# general config
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-PID=`pidof -o %PPID /usr/sbin/btnx`
-case "$1" in
- start)
- stat_busy "Starting btnx mouse daemon"
- modprobe uinput
- [ -z "$PID" ] && /usr/sbin/btnx -b -l > /dev/null
- if [ $? -gt 0 ]
- then
- stat_fail
- else
- add_daemon btnx
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping btnx mouse daemon"
- [ ! -z "$PID" ] && kill $PID &> /dev/null
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm -f /var/run/btnx.pid
- rm_daemon btnx
- stat_done
- fi
- ;;
- reload)
- stat_busy "Reloading btnx mouse daemon configuration"
- if [ "$PID" ]
- then
- kill -HUP $PID 2> /dev/null
- stat_done
- else
- stat_fail
- fi
- ;;
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart|reload}"
- ;;
-esac
-
-exit 0
diff --git a/btnx/makefile.patch b/btnx/makefile.patch
deleted file mode 100644
index 65c0691..0000000
--- a/btnx/makefile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile 2008-01-03 13:13:41.000000000 +0100
-+++ Makefile.new 2008-01-06 16:01:37.466242459 +0100
-@@ -1,8 +1,4 @@
-
--CC = gcc
--CFLAGS = -Wall -O2 #-g
--LFLAGS =
--
- DEPS = uinput.h btnx.h config_parser.h device.h revoco.h
- OBJ = btnx.o uinput.o config_parser.o device.o revoco.o
- BIN = btnx