summaryrefslogtreecommitdiffstats
path: root/celt
diff options
context:
space:
mode:
Diffstat (limited to 'celt')
-rw-r--r--celt/PKGBUILD28
-rw-r--r--celt/mumble11x.desktop11
2 files changed, 39 insertions, 0 deletions
diff --git a/celt/PKGBUILD b/celt/PKGBUILD
new file mode 100644
index 0000000..456bd46
--- /dev/null
+++ b/celt/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Lauri Niskanen <ape@ape3000.com>
+# Contributor: Ray Rashif <schivmeister@gmail.com>
+
+pkgname=celt
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="Low-latency audio communication codec"
+arch=(i686 x86_64)
+url="http://www.celt-codec.org"
+license=('BSD')
+depends=('libogg')
+options=('!libtool')
+source=(http://downloads.us.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('c7f6b8346e132b1a48dae0eff77ea9f0')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR="$pkgdir" install
+
+ ln -s libcelt0.so.0.0.0 $pkgdir/usr/lib/libcelt.so.0.7
+ ln -s libcelt0.so.0.0.0 $pkgdir/usr/lib/libcelt.so.0.7.1
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/BSD"
+}
+
diff --git a/celt/mumble11x.desktop b/celt/mumble11x.desktop
new file mode 100644
index 0000000..5dba0d0
--- /dev/null
+++ b/celt/mumble11x.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Mumble (1.1.X compatible)
+GenericName=Voice Chat
+Comment=Voice chat program (compatible with Mumble 1.1.X)
+Exec=mumble11x
+Icon=mumble
+Terminal=false
+Type=Application
+StartupNotify=false
+Categories=Network;Chat;Qt;
+Version=1.2.1