summaryrefslogtreecommitdiffstats
path: root/cower
diff options
context:
space:
mode:
Diffstat (limited to 'cower')
-rw-r--r--cower/PKGBUILD26
-rw-r--r--cower/namcap.log0
-rw-r--r--cower/set_curlopt_nosignal.patch22
3 files changed, 48 insertions, 0 deletions
diff --git a/cower/PKGBUILD b/cower/PKGBUILD
new file mode 100644
index 0000000..23f9e71
--- /dev/null
+++ b/cower/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Dave Reisner <d@falconindy.com>
+
+pkgname=cower
+pkgver=3.0.1
+pkgrel=1
+pkgdesc="A simple AUR agent with a pretentious name"
+arch=('i686' 'x86_64')
+url="http://github.com/falconindy/cower"
+license=('GPL')
+depends=('curl' 'yajl' 'pacman')
+makedepends=('perl')
+source=("https://github.com/downloads/falconindy/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('4dc3c13d3c980b8e4eb397aef94b3f27')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR=${pkgdir} install
+}
+
+# vim: ft=sh syn=sh
diff --git a/cower/namcap.log b/cower/namcap.log
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/cower/namcap.log
diff --git a/cower/set_curlopt_nosignal.patch b/cower/set_curlopt_nosignal.patch
new file mode 100644
index 0000000..76d7456
--- /dev/null
+++ b/cower/set_curlopt_nosignal.patch
@@ -0,0 +1,22 @@
+commit 9d7537ef064a23ed57551aa04283c398fc8d07f1
+Author: Dave Reisner <d@falconindy.com>
+Date: Thu Dec 30 20:14:36 2010 -0500
+
+ set CURLOPT_NOSIGNAL on all curl handles
+
+ As per curl_easy_setopt(3), this is particularly crucial of multi
+ threaded apps (hey that's us) which use timeouts to avoid sending them
+ signals and behaving badly (e.g. causing segfaults).
+
+diff --git a/cower.c b/cower.c
+index 7ba747c..23ff9bc 100644
+--- a/cower.c
++++ b/cower.c
+@@ -585,6 +585,7 @@ CURL *curl_create_easy_handle() {
+
+ curl_easy_setopt(handle, CURLOPT_USERAGENT, COWER_USERAGENT);
+ curl_easy_setopt(handle, CURLOPT_CONNECTTIMEOUT, 10L);
++ curl_easy_setopt(handle, CURLOPT_NOSIGNAL, 1L);
+ curl_easy_setopt(handle, CURLOPT_ENCODING, "deflate, gzip");
+
+ return(handle);