summaryrefslogtreecommitdiffstats
path: root/gadmin-samba/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'gadmin-samba/PKGBUILD')
-rw-r--r--gadmin-samba/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/gadmin-samba/PKGBUILD b/gadmin-samba/PKGBUILD
new file mode 100644
index 0000000..1be5b82
--- /dev/null
+++ b/gadmin-samba/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Florian Pritz <f-p@gmx.at>
+# Contributor: Andrea Scarpino <bash.lnx@gmail.com>
+# Contributor: Marcin Kaczorek <kaczus@karek.pl>
+
+pkgname=gadmin-samba
+pkgver=0.2.7
+pkgrel=1
+pkgdesc="An easy to use GTK+ frontend for the SAMBA file and print server"
+url="http://85.214.17.244/gadmintools/index.php?option=com_content&task=view&id=16&Itemid=30"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('gtk2' 'samba')
+replaces=('gsambad')
+install=${pkgname}.install
+source=("http://mange.dynalias.org/linux/${pkgname}/${pkgname}-${pkgver}.tar.gz" "makefile.patch")
+md5sums=('3cbe8828c766cae8651b7059367b3f02'
+ '9ff1869c836e2e755791d2ffc6349adf'
+ '2fdb7793c2ed5e9bfafd3d163d44ca31')
+options=(!emptydirs)
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -p0 < ${srcdir}/makefile.patch
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --sbindir=/usr/sbin
+ make || return 1
+ make DESTDIR=${pkgdir} install
+
+ install -D -m644 desktop/${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+}