summaryrefslogtreecommitdiffstats
path: root/gajim-hg/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'gajim-hg/PKGBUILD')
-rw-r--r--gajim-hg/PKGBUILD55
1 files changed, 28 insertions, 27 deletions
diff --git a/gajim-hg/PKGBUILD b/gajim-hg/PKGBUILD
index 71a8de6..ae8c565 100644
--- a/gajim-hg/PKGBUILD
+++ b/gajim-hg/PKGBUILD
@@ -1,48 +1,49 @@
-# Maintainer: Benjamin Richter <br@waldteufel-online.net>
+# Maintainer: Lev Lybin <lev at lybin dot org>
+# Contributor: Benjamin Richter <br@waldteufel-online.net>
# Contributor: Changaco <changaco@changaco.net>
# Contributor: Artyom Smirnov <smirnoffjr@gmail.com>
pkgname=gajim-hg
-pkgver=11794
+pkgver=12485
pkgrel=1
pkgdesc="Jabber/XMMP instant messenger client written in PyGTK"
arch=('i686' 'x86_64')
url="http://gajim.org"
-license=('GPL')
-depends=('python>=2.5' 'pygtk>=2.16' 'xdg-utils')
+license=('GPL3')
+depends=('python>=2.5' 'pygtk>=2.16' 'xdg-utils' 'python-pysqlite')
makedepends=('mercurial' 'intltool>=0.40.1')
optdepends=(
- 'libxss: idle'
- 'pyopenssl: secure SSL/TLS'
- 'pycrypto: End to end encryption'
- 'dbus-glib: link-local messaging (install avahi!)'
- 'avahi: link-local messaging (install dbus-glib!)'
- 'dnsutils: SRV support'
- 'gtkspell: Spell checking (install aspell-LANG!)'
- 'gnome-python-desktop: Keyring support'
- 'python-notify: Notification popups'
- 'dbus-python'
- 'farsight2: for Jingle support')
+ 'dbus-python: Python bindings for DBUS'
+ 'pyopenssl: for secure SSL/TLS'
+ 'notification-daemon: for desktop notification'
+ 'dnsutils: for SRV support'
+ 'libxss: for idle module'
+ 'gtkspell:spelling support (install aspell-LANG!)'
+ 'gnome-python-desktop: for GnomeKeyring support'
+ 'farsight2: video/voice support'
+ 'gstreamer0.10-good: video/voice support'
+ 'gstreamer0.10-bad: video/voice support'
+ 'pycrypto: End to end encryption'
+ 'dbus-glib: link-local messaging (install avahi!)'
+ 'avahi: link-local messaging (install dbus-glib!)'
+ 'python-notify: Notification popups')
+
provides=('gajim')
conflicts=('gajim' 'gajim-svn')
replaces=('gajim-svn')
-options=(!libtool)
install=gajim.install
-source=()
-md5sums=()
_hgroot=http://hg.gajim.org
_hgrepo=gajim
build() {
- rm -rf "{$srcdir}/build"
-
cd "${srcdir}/${_hgrepo}"
- [[ $(hg branch) == default ]] || hg update default
- hg archive "${srcdir}/build"
+ hg update default
+ ./autogen.sh --prefix=/usr
+ make
+}
- cd "${srcdir}/build"
- ./autogen.sh --prefix=/usr || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
-}
+package() {
+ cd "${srcdir}/${_hgrepo}"
+ make DESTDIR="${pkgdir}" install
+}