summaryrefslogtreecommitdiffstats
path: root/gajim-hg/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'gajim-hg/PKGBUILD')
-rw-r--r--gajim-hg/PKGBUILD49
1 files changed, 0 insertions, 49 deletions
diff --git a/gajim-hg/PKGBUILD b/gajim-hg/PKGBUILD
deleted file mode 100644
index ae8c565..0000000
--- a/gajim-hg/PKGBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Maintainer: Lev Lybin <lev at lybin dot org>
-# Contributor: Benjamin Richter <br@waldteufel-online.net>
-# Contributor: Changaco <changaco@changaco.net>
-# Contributor: Artyom Smirnov <smirnoffjr@gmail.com>
-
-pkgname=gajim-hg
-pkgver=12485
-pkgrel=1
-pkgdesc="Jabber/XMMP instant messenger client written in PyGTK"
-arch=('i686' 'x86_64')
-url="http://gajim.org"
-license=('GPL3')
-depends=('python>=2.5' 'pygtk>=2.16' 'xdg-utils' 'python-pysqlite')
-makedepends=('mercurial' 'intltool>=0.40.1')
-optdepends=(
- 'dbus-python: Python bindings for DBUS'
- 'pyopenssl: for secure SSL/TLS'
- 'notification-daemon: for desktop notification'
- 'dnsutils: for SRV support'
- 'libxss: for idle module'
- 'gtkspell:spelling support (install aspell-LANG!)'
- 'gnome-python-desktop: for GnomeKeyring support'
- 'farsight2: video/voice support'
- 'gstreamer0.10-good: video/voice support'
- 'gstreamer0.10-bad: video/voice support'
- 'pycrypto: End to end encryption'
- 'dbus-glib: link-local messaging (install avahi!)'
- 'avahi: link-local messaging (install dbus-glib!)'
- 'python-notify: Notification popups')
-
-provides=('gajim')
-conflicts=('gajim' 'gajim-svn')
-replaces=('gajim-svn')
-install=gajim.install
-
-_hgroot=http://hg.gajim.org
-_hgrepo=gajim
-
-build() {
- cd "${srcdir}/${_hgrepo}"
- hg update default
- ./autogen.sh --prefix=/usr
- make
-}
-
-package() {
- cd "${srcdir}/${_hgrepo}"
- make DESTDIR="${pkgdir}" install
-}