summaryrefslogtreecommitdiffstats
path: root/gcc43
diff options
context:
space:
mode:
Diffstat (limited to 'gcc43')
-rw-r--r--gcc43/PKGBUILD65
-rw-r--r--gcc43/buildfix_new_bison.patch243
-rw-r--r--gcc43/gcc-hash-style-both.patch163
-rw-r--r--gcc43/gcc_pure64.patch26
4 files changed, 0 insertions, 497 deletions
diff --git a/gcc43/PKGBUILD b/gcc43/PKGBUILD
deleted file mode 100644
index 63900ef..0000000
--- a/gcc43/PKGBUILD
+++ /dev/null
@@ -1,65 +0,0 @@
-# Maintainer: Carson Reynolds <carson@k2.t.u-tokyo.ac.jp>
-
-pkgname=gcc43
-_ver=4.3
-pkgver=4.3.4
-pkgrel=3
-pkgdesc="The GNU Compiler Collection"
-arch=('i686' 'x86_64')
-license=('GPL' 'LGPL')
-url="http://gcc.gnu.org"
-depends=('glibc' 'gmp' 'mpfr')
-makedepends=('flex' 'bison')
-options=('!libtool')
-
-source=(ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-{core,g++,fortran,objc,java}-${pkgver}.tar.bz2
- gcc_pure64.patch
- gcc-hash-style-both.patch
- buildfix_new_bison.patch)
-
-md5sums=('575b3220bb8e7060939c429fc8608d22'
- 'd526e34eec101b8c69254ed5215b6d41'
- '3e702a563d97bb2806dd81739c22806d'
- '37ba6440062ddf9bab43e6ae660c890b'
- 'dd41be44634d39d145cdb715cde39be6'
- '4030ee1c08dd1e843c0225b772360e76'
- 'bb420bc84b1104455b7230b1cd4b96c2'
- '6895f128e905bfcb26e328899235e553')
-
-build() {
- cd ${srcdir}/gcc-${pkgver}
- # Don't install libiberty
- sed -i 's/install_to_$(INSTALL_DEST) //' libiberty/Makefile.in
-
- if [ "${CARCH}" = "x86_64" ]; then
- patch -Np1 -i ../gcc_pure64.patch || return 1
- fi
- patch -Np0 -i ${srcdir}/gcc-hash-style-both.patch || return 1
- patch -Np0 -i ${srcdir}/buildfix_new_bison.patch || return 1
-
- echo ${pkgver} > gcc/BASE-VER
-
- # Don't run fixincludes
- sed -i -e 's@\./fixinc\.sh@-c true@' gcc/Makefile.in
-
- mkdir build
- cd build
- ../configure --prefix=/usr --enable-shared \
- --enable-languages=c,c++ \
- --enable-threads=posix --mandir=/usr/share/man --infodir=/usr/share/info \
- --enable-__cxa_atexit --disable-multilib --libdir=/usr/lib \
- --libexecdir=/usr/lib --enable-clocale=gnu --disable-libstdcxx-pch \
- --with-tune=generic \
- --disable-werror --enable-checking=release \
- --program-suffix=-${_ver} --enable-version-specific-runtime-libs
- make || return 1
- make -j1 DESTDIR=${pkgdir} install || return 1
-
- # Lazy way of dealing with conflicting man and info pages...
- rm -rf ${pkgdir}/usr/share
-
- # Create links for gcc-4.3 build environment (useful for CUDA)
- mkdir -p $pkgdir/opt/gcc-4.3
- ln -s /usr/bin/gcc-4.3 $pkgdir/opt/gcc-4.3/gcc
- ln -s /usr/bin/g++-4.3 $pkgdir/opt/gcc-4.3/g++
-} \ No newline at end of file
diff --git a/gcc43/buildfix_new_bison.patch b/gcc43/buildfix_new_bison.patch
deleted file mode 100644
index bd2eadf..0000000
--- a/gcc43/buildfix_new_bison.patch
+++ /dev/null
@@ -1,243 +0,0 @@
-
-
-
-
-<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
-"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
-<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1-strict.dtd ">
-<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
-<head>
-<title>Arch Linux Repositories [packages] View of /gcc/repos/core-i686/buildfix_new_bison.patch</title>
-<meta http-equiv="content-type" content="text/html; charset=utf-8" />
-<link rel="stylesheet" href="http://archlinux.org/media/arch.css" />
-<link rel="stylesheet" href="/static/styles.css" type="text/css" />
-
-<link rel="icon" href="http://archlinux.org/media/favicon.ico" type="image/x-icon" />
-<link rel="shortcut icon" href="http://archlinux.org/media/favicon.ico" type="image/x-icon" />
-<style type="text/css">
-div.searchbar {
-font-size: 13px;
-font-weight: bold;
-position: absolute;
-right: 0.2em;
-top: 152px;
-}
-</style>
-</head>
-<body>
-<div id="head_container">
-<div id="title">
-<div id="logo"><h1 id="archtitle"><a href="/" title="Arch Linux (Home)">Arch Linux</a></h1></div>
-</div>
-<div id="main_nav">
-<ul>
-<li><a href="http://archlinux.org/download/">Get Arch</a></li>
-<li><a href="http://aur.archlinux.org">AUR</a></li>
-<li><a href="http://bugs.archlinux.org">Bugs</a></li>
-<li><a href="http://wiki.archlinux.org">Wiki</a></li>
-<li><a href="http://bbs.archlinux.org">Forums</a></li>
-<li><a href="http://archlinux.org">Home</a></li>
-</ul>
-</div>
-<div id="ads">
-<script type="text/javascript"><!--
-google_ad_client = "pub-3170555743375154";
-google_ad_width = 468;
-google_ad_height = 60;
-google_ad_format = "468x60_as";
-google_color_border = "ffffff";
-google_color_bg = "ffffff";
-google_color_link = "0771A6";
-google_color_url = "99AACC";
-google_color_text = "000000";
-//--></script>
-<script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script>
-</div>
-</div>
-<div id="content">
-<div class="vc_navheader">
-
-<form method="get" action="/viewvc.cgi/">
-
-<div>
-<strong>
-
-<a href="/viewvc.cgi/">
-
-[packages]</a>
-/
-
-<a href="/viewvc.cgi/gcc/">
-
-gcc</a>
-/
-
-<a href="/viewvc.cgi/gcc/repos/">
-
-repos</a>
-/
-
-<a href="/viewvc.cgi/gcc/repos/core-i686/">
-
-core-i686</a>
-/
-
-<a href="/viewvc.cgi/gcc/repos/core-i686/buildfix_new_bison.patch?view=log">
-
-buildfix_new_bison.patch</a>
-
-
-</strong>
-
-</div>
-<div class="searchbar">
-
-
-<strong>Repository:</strong>
-<select name="root" onchange="submit()">
-
-
-<option value="*viewroots*">Repository Listing</option>
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-
-<optgroup label="CVS Repositories"><option>community</option><option>core</option><option>extra</option><option>unstable</option></optgroup>
-
-
-<optgroup label="Subversion Repositories"><option selected="selected">packages</option></optgroup>
-
-</select>
-<input type="submit" value="Go" />
-
-</div>
-
-</form>
-
-</div>
-<h1>View of /gcc/repos/core-i686/buildfix_new_bison.patch</h1>
-
-<p style="margin:0;">
-
-<a href="/viewvc.cgi/gcc/repos/core-i686/"><img src="/static/images/back_small.png" width="16" height="16" alt="Parent Directory" /> Parent Directory</a>
-
-| <a href="/viewvc.cgi/gcc/repos/core-i686/buildfix_new_bison.patch?view=log#rev19322"><img src="/static/images/log.png" width="16" height="16" alt="Revision Log" /> Revision Log</a>
-
-
-
-
-</p>
-
-<hr />
-<div class="vc_summary">
-Revision <a href="/viewvc.cgi?view=rev&amp;revision=19322"><strong>19322</strong></a> -
-(<a href="/viewvc.cgi/gcc/repos/core-i686/buildfix_new_bison.patch?revision=19322"><strong>download</strong></a>)
-
-(<a href="/viewvc.cgi/gcc/repos/core-i686/buildfix_new_bison.patch?annotate=19322"><strong>annotate</strong></a>)
-
-<br /><em>Thu Nov 20 11:36:53 2008 UTC</em>
-(6 months ago)
-by <em>andyrtr</em>
-
-<br />Original Path: <a href="/viewvc.cgi/gcc/trunk/buildfix_new_bison.patch?view=log&amp;pathrev=19322"><em>gcc/trunk/buildfix_new_bison.patch</em></a>
-
-
-
-
-
-
-<br />File size: 423 byte(s)
-
-
-
-<pre class="vc_log">upgpkg: gcc 4.3.2-2
- rebuild for new binutils/glibc</pre>
-
-</div>
-<div id="vc_markup"><pre><PRE>
---- gcc/treelang/parse.y 2007-07-18 08:19:29.000000000 +0000
-+++ gcc/treelang/parse.y.new 2008-11-20 06:40:00.013275486 +0000
-@@ -369,7 +369,6 @@
- current_function = NULL;
- }
- ;
--
- variable_defs_opt:
- /* Nil. */ {
- $$ = 0;
-@@ -685,9 +684,9 @@
-
- expressions_with_commas_opt:
- /* Nil. */ {
--$$ = 0
-+$$ = 0;
- }
--|expressions_with_commas { $$ = $1 }
-+|expressions_with_commas { $$ = $1; }
- ;
-
- expressions_with_commas:
-</PRE>
-</pre></div>
-
-<hr />
-<div class="foot">
-Copyright &copy; 2002-2008
-<a href="mailto:jvinet@zeroflux.org" title="contact Judd Vinet">Judd Vinet</a> and
-<a href="mailto:aaron@archlinux.org" title="contact Aaron Griffin">Aaron Griffin</a>.
-<br />
-The Arch Linux name and logo are recognized trademarks. Some rights reserved.
-</div>
-<script type="text/javascript">
-var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
-document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
-</script>
-<script type="text/javascript">
-var pageTracker = _gat._getTracker("UA-3589020-1");
-pageTracker._setDomainName("archlinux.org");
-pageTracker._initData();
-pageTracker._trackPageview();
-</script>
-</body>
-</html>
-
diff --git a/gcc43/gcc-hash-style-both.patch b/gcc43/gcc-hash-style-both.patch
deleted file mode 100644
index 8fea758..0000000
--- a/gcc43/gcc-hash-style-both.patch
+++ /dev/null
@@ -1,163 +0,0 @@
-#! /bin/sh -e
-
-# DP: Link using --hash-style=both (alpha, amd64, ia64, i386, powerpc, ppc64, s390, sparc)
-
-dir=
-if [ $# -eq 3 -a "$2" = '-d' ]; then
- pdir="-d $3"
- dir="$3/"
-elif [ $# -ne 1 ]; then
- echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
- exit 1
-fi
-case "$1" in
- -patch)
- patch $pdir -f --no-backup-if-mismatch -p0 < $0
- #cd ${dir}gcc && autoconf
- ;;
- -unpatch)
- patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
- #rm ${dir}gcc/configure
- ;;
- *)
- echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
- exit 1
-esac
-exit 0
-
-2006-07-11 Jakub Jelinek <jakub@redhat.com>
-
- * config/i386/linux.h (LINK_SPEC): Add --hash-style=both.
- * config/i386/linux64.h (LINK_SPEC): Likewise.
- * config/rs6000/sysv4.h (LINK_OS_LINUX_SPEC): Likewise.
- * config/rs6000/linux64.h (LINK_OS_LINUX_SPEC32,
- LINK_OS_LINUX_SPEC64): Likewise.
- * config/s390/linux.h (LINK_SPEC): Likewise.
- * config/ia64/linux.h (LINK_SPEC): Likewise.
- * config/sparc/linux.h (LINK_SPEC): Likewise.
- * config/sparc/linux64.h (LINK_SPEC, LINK_ARCH32_SPEC,
- LINK_ARCH64_SPEC): Likewise.
- * config/alpha/linux-elf.h (LINK_SPEC): Likewise.
-
---- gcc/config/alpha/linux-elf.h.orig 2007-08-04 08:55:58.000000000 +0200
-+++ gcc/config/alpha/linux-elf.h 2007-09-01 15:47:26.605865578 +0200
-@@ -39,7 +39,7 @@
-
- #define ELF_DYNAMIC_LINKER LINUX_DYNAMIC_LINKER
-
--#define LINK_SPEC "-m elf64alpha %{G*} %{relax:-relax} \
-+#define LINK_SPEC "-m elf64alpha --hash-style=both %{G*} %{relax:-relax} \
- %{O*:-O3} %{!O*:-O1} \
- %{shared:-shared} \
- %{!shared: \
---- gcc/config/s390/linux.h.orig 2007-08-04 08:55:59.000000000 +0200
-+++ gcc/config/s390/linux.h 2007-09-01 15:47:26.605865578 +0200
-@@ -77,7 +77,7 @@
-
- #undef LINK_SPEC
- #define LINK_SPEC \
-- "%{m31:-m elf_s390}%{m64:-m elf64_s390} \
-+ "%{m31:-m elf_s390}%{m64:-m elf64_s390} --hash-style=both \
- %{shared:-shared} \
- %{!shared: \
- %{static:-static} \
---- gcc/config/sparc/linux.h.orig 2007-08-04 08:56:01.000000000 +0200
-+++ gcc/config/sparc/linux.h 2007-09-01 15:47:26.605865578 +0200
-@@ -132,7 +132,7 @@
-
-
- #undef LINK_SPEC
--#define LINK_SPEC "-m elf32_sparc -Y P,/usr/lib %{shared:-shared} \
-+#define LINK_SPEC "-m elf32_sparc --hash-style=both -Y P,/usr/lib %{shared:-shared} \
- %{!mno-relax:%{!r:-relax}} \
- %{!shared: \
- %{!ibcs: \
---- gcc/config/sparc/linux64.h.orig 2007-08-04 08:56:01.000000000 +0200
-+++ gcc/config/sparc/linux64.h 2007-09-01 15:47:26.605865578 +0200
-@@ -166,7 +166,7 @@
- { "link_arch_default", LINK_ARCH_DEFAULT_SPEC }, \
- { "link_arch", LINK_ARCH_SPEC },
-
--#define LINK_ARCH32_SPEC "-m elf32_sparc -Y P,/usr/lib %{shared:-shared} \
-+#define LINK_ARCH32_SPEC "-m elf32_sparc --hash-style=both -Y P,/usr/lib %{shared:-shared} \
- %{!shared: \
- %{!ibcs: \
- %{!static: \
-@@ -175,7 +175,7 @@
- %{static:-static}}} \
- "
-
--#define LINK_ARCH64_SPEC "-m elf64_sparc -Y P,/usr/lib64 %{shared:-shared} \
-+#define LINK_ARCH64_SPEC "-m elf64_sparc --hash-style=both -Y P,/usr/lib64 %{shared:-shared} \
- %{!shared: \
- %{!ibcs: \
- %{!static: \
-@@ -256,7 +256,7 @@
- #else /* !SPARC_BI_ARCH */
-
- #undef LINK_SPEC
--#define LINK_SPEC "-m elf64_sparc -Y P,/usr/lib64 %{shared:-shared} \
-+#define LINK_SPEC "-m elf64_sparc --hash-style=both -Y P,/usr/lib64 %{shared:-shared} \
- %{!shared: \
- %{!ibcs: \
- %{!static: \
---- gcc/config/i386/linux.h.orig 2007-08-04 08:56:07.000000000 +0200
-+++ gcc/config/i386/linux.h 2007-09-01 15:47:26.605865578 +0200
-@@ -108,7 +108,7 @@
- { "dynamic_linker", LINUX_DYNAMIC_LINKER }
-
- #undef LINK_SPEC
--#define LINK_SPEC "-m %(link_emulation) %{shared:-shared} \
-+#define LINK_SPEC "-m %(link_emulation) --hash-style=both %{shared:-shared} \
- %{!shared: \
- %{!ibcs: \
- %{!static: \
---- gcc/config/i386/linux64.h.orig 2007-08-04 08:56:07.000000000 +0200
-+++ gcc/config/i386/linux64.h 2007-09-01 15:48:27.336781690 +0200
-@@ -65,7 +65,7 @@
- #endif
-
- #undef LINK_SPEC
--#define LINK_SPEC "%{" SPEC_64 ":-m elf_x86_64} %{" SPEC_32 ":-m elf_i386} \
-+#define LINK_SPEC "%{" SPEC_64 ":-m elf_x86_64} %{" SPEC_32 ":-m elf_i386} --hash-style=both \
- %{shared:-shared} \
- %{!shared: \
- %{!static: \
---- gcc/config/ia64/linux.h.orig 2006-12-12 18:59:53.000000000 +0100
-+++ gcc/config/ia64/linux.h 2007-09-01 15:47:26.605865578 +0200
-@@ -40,7 +40,7 @@
- #define GLIBC_DYNAMIC_LINKER "/lib/ld-linux-ia64.so.2"
-
- #undef LINK_SPEC
--#define LINK_SPEC "\
-+#define LINK_SPEC "--hash-style=both \
- %{shared:-shared} \
- %{!shared: \
- %{!static: \
---- gcc/config/rs6000/sysv4.h.orig 2007-08-08 23:37:49.000000000 +0200
-+++ gcc/config/rs6000/sysv4.h 2007-09-01 15:47:26.615865729 +0200
-@@ -901,7 +901,7 @@
- #define LINUX_DYNAMIC_LINKER \
- CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER, UCLIBC_DYNAMIC_LINKER)
-
--#define LINK_OS_LINUX_SPEC "-m elf32ppclinux %{!shared: %{!static: \
-+#define LINK_OS_LINUX_SPEC "-m elf32ppclinux --hash-style=both %{!shared: %{!static: \
- %{rdynamic:-export-dynamic} \
- %{!dynamic-linker:-dynamic-linker " LINUX_DYNAMIC_LINKER "}}}"
-
---- gcc/config/rs6000/linux64.h.orig 2007-08-04 08:56:12.000000000 +0200
-+++ gcc/config/rs6000/linux64.h 2007-09-01 15:47:26.615865729 +0200
-@@ -354,11 +354,11 @@
- CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER64, UCLIBC_DYNAMIC_LINKER64)
-
-
--#define LINK_OS_LINUX_SPEC32 "-m elf32ppclinux %{!shared: %{!static: \
-+#define LINK_OS_LINUX_SPEC32 "-m elf32ppclinux --hash-style=both %{!shared: %{!static: \
- %{rdynamic:-export-dynamic} \
- %{!dynamic-linker:-dynamic-linker " LINUX_DYNAMIC_LINKER32 "}}}"
-
--#define LINK_OS_LINUX_SPEC64 "-m elf64ppc %{!shared: %{!static: \
-+#define LINK_OS_LINUX_SPEC64 "-m elf64ppc --hash-style=both %{!shared: %{!static: \
- %{rdynamic:-export-dynamic} \
- %{!dynamic-linker:-dynamic-linker " LINUX_DYNAMIC_LINKER64 "}}}"
-
diff --git a/gcc43/gcc_pure64.patch b/gcc43/gcc_pure64.patch
deleted file mode 100644
index 8c0baf8..0000000
--- a/gcc43/gcc_pure64.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -Naur gcc-4.2.0.orig/gcc/config/i386/linux64.h gcc-4.2.0/gcc/config/i386/linux64.h
---- gcc-4.2.0.orig/gcc/config/i386/linux64.h 2007-05-16 19:21:19.000000000 -0400
-+++ gcc-4.2.0/gcc/config/i386/linux64.h 2007-05-18 17:04:05.000000000 -0400
-@@ -49,8 +49,8 @@
- When the -shared link option is used a final link is not being
- done. */
-
--#define GLIBC_DYNAMIC_LINKER32 "/lib/ld-linux.so.2"
--#define GLIBC_DYNAMIC_LINKER64 "/lib64/ld-linux-x86-64.so.2"
-+#define GLIBC_DYNAMIC_LINKER32 "/lib32/ld-linux.so.2"
-+#define GLIBC_DYNAMIC_LINKER64 "/lib/ld-linux-x86-64.so.2"
-
- #undef LINK_SPEC
- #define LINK_SPEC "%{!m32:-m elf_x86_64} %{m32:-m elf_i386} \
-diff -Naur gcc-4.2.0.orig/gcc/config/i386/t-linux64 gcc-4.2.0/gcc/config/i386/t-linux64
---- gcc-4.2.0.orig/gcc/config/i386/t-linux64 2007-05-16 19:21:19.000000000 -0400
-+++ gcc-4.2.0/gcc/config/i386/t-linux64 2007-05-18 17:04:36.000000000 -0400
-@@ -6,7 +6,7 @@
-
- MULTILIB_OPTIONS = m64/m32
- MULTILIB_DIRNAMES = 64 32
--MULTILIB_OSDIRNAMES = ../lib64 $(if $(wildcard $(shell echo $(SYSTEM_HEADER_DIR))/../../usr/lib32),../lib32,../lib)
-+MULTILIB_OSDIRNAMES = ../lib ../lib32
-
- LIBGCC = stmp-multilib
- INSTALL_LIBGCC = install-multilib