summaryrefslogtreecommitdiffstats
path: root/gimp-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'gimp-git/PKGBUILD')
-rw-r--r--gimp-git/PKGBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/gimp-git/PKGBUILD b/gimp-git/PKGBUILD
new file mode 100644
index 0000000..f248c6e
--- /dev/null
+++ b/gimp-git/PKGBUILD
@@ -0,0 +1,61 @@
+# Contributor: Alessio Biancalana <dottorblaster@gmail.com>
+
+pkgname=gimp-git
+pkgver=20100109
+pkgrel=1
+pkgdesc="GNU Image Manipulation Program (GIT Version)"
+arch=('i686' 'x86_64')
+url="http://www.gimp.org/"
+license=('GPL')
+depends=('gtk2>=2.10' 'lcms>=1.16' 'libxpm>=3.5.6' 'libwmf>=0.2.8' \
+ 'libxmu>=1.0.3' 'librsvg>=2.16.1' 'libmng>=1.0.9' 'desktop-file-utils' \
+ 'libexif>=0.6.13' 'libart-lgpl>=2.3.19' 'pygtk>=2.10.4' 'dbus-glib' 'gtk-doc')
+makedepends=('gutenprint>=5.0.0' 'intltool>=0.35.5' 'libgtkhtml>=2.6.3' \
+ 'gnome-python>=2.16.2' 'poppler>=0.6' 'pkgconfig>=0.21' \
+ 'libgnomeprintui>=2.18' 'alsa-lib>=1.0.0' 'gegl-git'
+'libtool>=1.5' 'autoconf>=2.54' 'automake>=1.9.6' 'libxslt' 'libwebkit'
+'pango' 'gettext' 'git')
+options=('!libtool' '!makeflags')
+provides=('gimp')
+conflicts=('gimp' 'gimp-devel')
+source=('gimp-git.install' 'linux.gpl')
+install=('gimp-git.install')
+md5sums=('c49a84c5333fbe0b49b49911a3da9d20'
+ 'bb27bc214261d36484093e857f015f38')
+
+_gitroot=('git://git.gnome.org/gimp')
+_gitname=('gimp')
+
+build() {
+ cd $startdir/src
+ msg "Connecting to gnome.org git server...."
+ rm -rf $startdir/src/$_gitname-build
+
+ if [[ -d $_gitname ]]; then
+ cd $_gitname || return 1
+# git pull origin || return 1
+# else
+# git clone $_gitroot $_gitname || return 1
+ fi
+ msg " checkout done."
+
+ msg "Starting make..."
+ cd "$srcdir"
+ rm -r "$srcdir/$_gitname-build"
+ cp -r $srcdir/$_gitname $_gitname-build
+ cd $_gitname-build
+
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc \
+ --enable-mp --enable-gimp-console --disable-devel-docs \
+ --enable-python --with-gif-compression=lzw \
+ --without-aa
+ make || return 1
+ make DESTDIR=${startdir}/pkg install-strip || return 1
+
+ install -Dm644 ${startdir}/src/linux.gpl \
+ ${startdir}/pkg/usr/share/gimp/2.0/palettes/Linux.gpl
+
+ #ln -s gimp-2.5 ${startdir}/pkg/usr/bin/gimp
+ #ln -s gimp-console-2.5 ${startdir}/pkg/usr/bin/gimp-console
+ #ln -s gimp-remote-2.5 ${startdir}/pkg/usr/bin/gimp-remote
+}