summaryrefslogtreecommitdiffstats
path: root/highlight/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'highlight/PKGBUILD')
-rw-r--r--highlight/PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/highlight/PKGBUILD b/highlight/PKGBUILD
index 332fe2c..136b3d1 100644
--- a/highlight/PKGBUILD
+++ b/highlight/PKGBUILD
@@ -1,20 +1,23 @@
# Contributor: Jan Fader <jan.fader@web.de>
pkgname=highlight
-pkgver=2.16
+pkgver=3.1
+pkgver2=beta
pkgrel=1
pkgdesc="Highlight converts sourcecode to HTML, XHTML, RTF, LaTeX, TeX, XML and terminal escape sequences with coloured syntax highlighting. Language definitions, colour themes and indentation schemes are customizable"
url="http://www.andre-simon.de/doku/highlight/highlight.html"
license=('GPL')
arch=('i686' 'x86_64')
+depends=('boost')
install=
-source=(http://www.andre-simon.de/zip/$pkgname-$pkgver.tar.bz2)
-md5sums=('08f1429a6db258ab1a7eecbb4e0d44b2')
+source=(http://www.andre-simon.de/zip/$pkgname-$pkgver-$pkgver2.tar.bz2 make.patch)
+md5sums=('477cd7d61a6a8f665b5bdda4d75ba40f' '070f85f21eebf7afd89ab2a8d83e08d2')
build() {
- cd "$startdir/src/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver-$pkgver2"
+ patch -i $srcdir/make.patch
make || return 1
- make DESTDIR="$startdir/pkg" install
+ make DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et: