summaryrefslogtreecommitdiffstats
path: root/imagemagick-nox/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'imagemagick-nox/PKGBUILD')
-rw-r--r--imagemagick-nox/PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/imagemagick-nox/PKGBUILD b/imagemagick-nox/PKGBUILD
new file mode 100644
index 0000000..b6aecb0
--- /dev/null
+++ b/imagemagick-nox/PKGBUILD
@@ -0,0 +1,54 @@
+# $Id$
+# Maintainer: Eric Belanger <eric@archlinux.org>
+
+# NOTE: To circumvent linking problems (FS#10574), this package must now be built the following way:
+# install old package, build new package, install new package, rebuild
+# Just uninstalling ImageMagick before build fails as it is used during the build processs
+
+pkgname=imagemagick-nox
+pkgver=6.6.0.9
+pkgrel=1
+pkgdesc="An image viewing/manipulation program, without X dependencies"
+arch=('i686' 'x86_64')
+url="http://www.imagemagick.org/"
+license=('custom')
+depends=('lcms>=1.18-2' 'gcc-libs' 'openexr>=1.6.1' 'libtool>=2.2' 'heimdal>=1.2.1' 'bzip2' 'libxml2')
+provides=('imagemagick')
+options=('!makeflags' '!docs')
+source=(ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-${pkgver%.*}-${pkgver##*.}.tar.bz2 \
+ libpng_mmx_patch_x86_64.patch add_delegate.patch perlmagick.rpath.patch)
+
+build() {
+ cd "${srcdir}/ImageMagick-${pkgver%.*}-${pkgver##*.}"
+
+ if [ "${CARCH}" = "x86_64" ]; then
+ patch -Np1 < ../libpng_mmx_patch_x86_64.patch || return 1
+ fi
+
+ patch -p0 < ../add_delegate.patch || return 1
+ patch -p0 < ../perlmagick.rpath.patch || return 1
+ sed -i "s/with_autotrace='no'/with_autotrace='yes'/" configure || return 1
+
+ # When there is a soname bump, remove 'LIBS=-lMagickWand' from configure line and build/install. Then, readd 'LIBS=-lMagickWand' and build/install twice.
+ LIBS=-lMagickWand ./configure --prefix=/usr --without-modules --disable-static --enable-openmp \
+ --without-x --without-wmf --with-openexr --with-xml \
+ --without-gslib --with-perl --with-perl-options="INSTALLDIRS=vendor" \
+ --without-gvc --without-djvu --without-autotrace --with-jp2 \
+ --without-jbig --without-fpx --without-dps || return 1
+
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE" || return 1
+ install -D -m644 NOTICE "${pkgdir}/usr/share/licenses/${pkgname}/NOTICE" || return 1
+
+ #Cleaning
+ find ${pkgdir} -name '*.bs' -exec rm {} \; || return 1
+ find ${pkgdir} -name '.packlist' -exec rm {} \; || return 1
+ find ${pkgdir} -name 'perllocal.pod' -exec rm {} \; || return 1
+
+ rm -f ${pkgdir}/usr/lib/*.la || return 1
+}
+md5sums=('c04030c3d4649bee4d6a891a16e031a3'
+ '069980fc2590c02aed86420996259302'
+ '7f5851c4450b73d52df55c7e806cc316'
+ 'ff9974decbfe9846f8e347239d87e4eb')