summaryrefslogtreecommitdiffstats
path: root/iron
diff options
context:
space:
mode:
Diffstat (limited to 'iron')
-rw-r--r--iron/LICENSE27
-rw-r--r--iron/PKGBUILD48
-rw-r--r--iron/iron.desktop10
-rw-r--r--iron/iron.install14
-rw-r--r--iron/iron.pngbin0 -> 77287 bytes
-rw-r--r--iron/iron.sh2
-rw-r--r--iron/libjpeg.so.62-i686.xzbin0 -> 60900 bytes
-rw-r--r--iron/libjpeg.so.62-x86_64.xzbin0 -> 65852 bytes
8 files changed, 101 insertions, 0 deletions
diff --git a/iron/LICENSE b/iron/LICENSE
new file mode 100644
index 0000000..9314092
--- /dev/null
+++ b/iron/LICENSE
@@ -0,0 +1,27 @@
+// Copyright (c) 2006-2008 The Chromium Authors. All rights reserved.
+//
+// Redistribution and use in source and binary forms, with or without
+// modification, are permitted provided that the following conditions are
+// met:
+//
+// * Redistributions of source code must retain the above copyright
+// notice, this list of conditions and the following disclaimer.
+// * Redistributions in binary form must reproduce the above
+// copyright notice, this list of conditions and the following disclaimer
+// in the documentation and/or other materials provided with the
+// distribution.
+// * Neither the name of Google Inc. nor the names of its
+// contributors may be used to endorse or promote products derived from
+// this software without specific prior written permission.
+//
+// THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+// "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+// LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+// A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+// OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+// SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+// LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+// DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+// THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+// (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+// OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/iron/PKGBUILD b/iron/PKGBUILD
new file mode 100644
index 0000000..9109707
--- /dev/null
+++ b/iron/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: xduugu
+pkgname=iron
+pkgver=4.0.275.2
+pkgrel=3
+pkgdesc="A web browser based on chromium without Google's tracking 'features'"
+arch=('i686' 'x86_64')
+url="http://www.srware.net/en/software_srware_iron.php"
+license=('custom:BSD')
+depends=('alsa-lib' 'libjpeg6' 'libpng12' 'nss' 'ttf-dejavu')
+provides=("chromium=$pkgver")
+install=$pkgname.install
+source=(http://www.srware.net/downloads/$pkgname-linux.tar.gz
+ $pkgname{.desktop,.png,.sh} LICENSE)
+md5sums=('25d8756de52092b83108ac29e70c635f'
+ '22123a1dd05575b0edfdebdae61018fe'
+ '60df76c38381e46577505b0c61cea017'
+ '6ec430e5597388492b413b152c9587ac'
+ '30032c6c531632af6547fa360395acd3')
+sha256sums=('8083cd82964890fc128e75a0e0be2de2e4e689a20fad25606eba0e65da35ef36'
+ 'd45acaf8cc76f13f3274e2915a499e321efb59d5ff4f75425b9089cafeb18fd2'
+ '77c29198ff3079f4be5469023a5317c18dd7ef9ce34efd3ae4ca0be09d5de285'
+ '746148eba30c710dd2ad091afae102bf609501ebbdf8e2633cc88f2fe5262189'
+ 'ec68693372a025d4cba5214a0b97c66ae62025c80cc34ef6c01c92b32bd0f2d6')
+
+# x86_64 source
+if [[ $CARCH == x86_64 ]]; then
+ source[0]=${source[0]/.tar./-64.tar.}
+ md5sums[0]='cb8f8f037fc51595965c6fc5e1073429'
+ sha256sums[0]='c4dc670eb67030eeba1efad09514570a88f78d03321ee093e3ba96331d63b88f'
+fi
+
+build() {
+ install -Dm755 $pkgname.sh "$pkgdir/usr/bin/$pkgname" &&
+ install -d "$pkgdir/opt" &&
+ mv $(echo ${source[0]##*/} | sed 's/\..*//') "$pkgdir/opt/$pkgname" &&
+ cd "$pkgdir/opt/$pkgname" &&
+ rm -f product_logo_48.png README xdg-settings &&
+ ln -s /lib/libBrokenLocale.so.1 libgconf-2.so.4 &&
+ chmod a=r,u+w,a+X -R . &&
+ chmod a+x $pkgname chrome_sandbox libffmpegsumo.so &&
+ cd $OLDPWD || return 1
+
+ install -Dm644 $pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png" &&
+ install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop" &&
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE" || return 1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/iron/iron.desktop b/iron/iron.desktop
new file mode 100644
index 0000000..4454877
--- /dev/null
+++ b/iron/iron.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Name=Iron Web Browser
+Comment=Browse the World Wide Web
+Icon=iron
+Exec=iron
+Terminal=false
+Type=Application
+Categories=Network;
+StartupWMClass=Iron
diff --git a/iron/iron.install b/iron/iron.install
new file mode 100644
index 0000000..9f27e05
--- /dev/null
+++ b/iron/iron.install
@@ -0,0 +1,14 @@
+post_install() {
+ [ -x /usr/bin/update-desktop-database ] || return 0
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/iron/iron.png b/iron/iron.png
new file mode 100644
index 0000000..73e5d7a
--- /dev/null
+++ b/iron/iron.png
Binary files differ
diff --git a/iron/iron.sh b/iron/iron.sh
new file mode 100644
index 0000000..f4da2c1
--- /dev/null
+++ b/iron/iron.sh
@@ -0,0 +1,2 @@
+#!/bin/bash
+LD_LIBRARY_PATH="/usr/lib:/opt/iron" /opt/iron/iron "$@"
diff --git a/iron/libjpeg.so.62-i686.xz b/iron/libjpeg.so.62-i686.xz
new file mode 100644
index 0000000..b836fd1
--- /dev/null
+++ b/iron/libjpeg.so.62-i686.xz
Binary files differ
diff --git a/iron/libjpeg.so.62-x86_64.xz b/iron/libjpeg.so.62-x86_64.xz
new file mode 100644
index 0000000..b7bfb30
--- /dev/null
+++ b/iron/libjpeg.so.62-x86_64.xz
Binary files differ