summaryrefslogtreecommitdiffstats
path: root/libjpeg6
diff options
context:
space:
mode:
Diffstat (limited to 'libjpeg6')
-rw-r--r--libjpeg6/PKGBUILD43
-rw-r--r--libjpeg6/locale-fixes.patch41
2 files changed, 0 insertions, 84 deletions
diff --git a/libjpeg6/PKGBUILD b/libjpeg6/PKGBUILD
deleted file mode 100644
index 6a24d66..0000000
--- a/libjpeg6/PKGBUILD
+++ /dev/null
@@ -1,43 +0,0 @@
-# Contributor: Mikael Eriksson <mikael_eriksson@miffe.org>
-# Resurected from svn, originaly by
-# Maintainer: Allan McRae <allan@archlinux.org>
-# Committer: Judd Vinet <jvinet@zeroflux.org>
-
-pkgname=libjpeg6
-pkgver=6b
-pkgrel=9
-pkgdesc="Library of JPEG support functions"
-arch=('i686' 'x86_64')
-url="http://www.ijg.org/"
-license=('custom')
-depends=('glibc')
-makedepends=('libtool')
-options=(!libtool)
-source=("ftp://ftp.debian.org/debian/pool/main/libj/libjpeg6b/libjpeg6b_6b.orig.tar.gz"
- "locale-fixes.patch")
-md5sums=('dbd5f3b47ed13132f04c685d608a7547'
- 'a0910de4ba7bb7526032d86bb0297de4')
-
-build() {
- cd $srcdir/jpeg-$pkgver
- cp /usr/share/libtool/config/config.{guess,sub} .
- sed -i "s#./libtool#libtool#" configure
- patch -p1 -i "$srcdir/locale-fixes.patch"
- ./configure --prefix=/usr --enable-shared --enable-static
- make LIBTOOL="libtool --tag=CC" || return 1
- mkdir -p $pkgdir/usr/{bin,lib,include,share/man/man1}
- make prefix=$pkgdir/usr mandir=$pkgdir/usr/share/man/man1 install
- install -m644 jpegint.h $pkgdir/usr/include
- install -Dm644 README $pkgdir/usr/share/licenses/libjpeg6/README
- # Fix /usr/bin
- for fn in $pkgdir/usr/bin/*; do mv $fn ${fn}6; done
- # Fix /usr/lib
- rm $pkgdir/usr/lib/libjpeg.{a,so}
- # Fix /usr/share/man
- for fn in $pkgdir/usr/share/man/man1/*; do mv $fn ${fn%.1}6.1; done
- # Fix /usr/include
- mkdir -p $pkgdir/usr/include/libjpeg6
- mv $pkgdir/usr/include/*.h $pkgdir/usr/include/libjpeg6
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/libjpeg6/locale-fixes.patch b/libjpeg6/locale-fixes.patch
deleted file mode 100644
index 3bc3364..0000000
--- a/libjpeg6/locale-fixes.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-The LANG vars aren't reset early enough so when sed tries to use [a-zA-Z] in
-option parsing, it may break.
-
-http://bugs.gentoo.org/103483
-
---- jpeg/configure
-+++ jpeg/configure
-@@ -54,6 +54,16 @@
- infodir='${prefix}/info'
- mandir='${prefix}/man'
-
-+# NLS nuisances.
-+# Only set these to C if already set. These must not be set unconditionally
-+# because not all systems understand e.g. LANG=C (notably SCO).
-+# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
-+# Non-C LC_CTYPE values break the ctype check.
-+if test "${LANG+set}" = set; then LANG=C; export LANG; fi
-+if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
-+if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
-+if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
-+
- # Initialize some other variables.
- subdirs=
- MFLAGS= MAKEFLAGS=
-@@ -452,16 +463,6 @@
- esac
- done
-
--# NLS nuisances.
--# Only set these to C if already set. These must not be set unconditionally
--# because not all systems understand e.g. LANG=C (notably SCO).
--# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
--# Non-C LC_CTYPE values break the ctype check.
--if test "${LANG+set}" = set; then LANG=C; export LANG; fi
--if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
--if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
--if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
--
- # confdefs.h avoids OS command line length limits that DEFS can exceed.
- rm -rf conftest* confdefs.h
- # AIX cpp loses on an empty file, so make sure it contains at least a newline.