summaryrefslogtreecommitdiffstats
path: root/mac/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'mac/PKGBUILD')
-rw-r--r--mac/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/mac/PKGBUILD b/mac/PKGBUILD
new file mode 100644
index 0000000..6c40c9c
--- /dev/null
+++ b/mac/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: stonecrest <stonecrest[at]gmail[dot]com>
+
+pkgname=mac
+pkgver=3.99u4b5
+pkgrel=4
+pkgdesc="APE codec and decompressor"
+arch=('any')
+url="http://supermmx.org/linux/mac"
+license=('unknown')
+depends=()
+makedepends=('gcc' 'yasm' 'gcc-libs')
+source=(http://freshgen.googlecode.com/files/mac-3.99-u4-b5.tar.gz
+ gcc4_errors.patch)
+md5sums=('75716b342e07deae58f56a2522362006'
+ '771c071831871fe8803d139a56515e86')
+
+build() {
+ cd ${srcdir}/$pkgname-3.99-u4-b5
+ patch -Np1 -i ${srcdir}/gcc4_errors.patch || return 1
+ ./configure --prefix=/usr --enable-assembly=yes
+ make || return 1
+ make DESTDIR=${pkgdir} install
+}