summaryrefslogtreecommitdiffstats
path: root/mac
diff options
context:
space:
mode:
Diffstat (limited to 'mac')
-rw-r--r--mac/PKGBUILD23
-rw-r--r--mac/gcc4_errors.patch26
2 files changed, 0 insertions, 49 deletions
diff --git a/mac/PKGBUILD b/mac/PKGBUILD
deleted file mode 100644
index 6c40c9c..0000000
--- a/mac/PKGBUILD
+++ /dev/null
@@ -1,23 +0,0 @@
-# Contributor: stonecrest <stonecrest[at]gmail[dot]com>
-
-pkgname=mac
-pkgver=3.99u4b5
-pkgrel=4
-pkgdesc="APE codec and decompressor"
-arch=('any')
-url="http://supermmx.org/linux/mac"
-license=('unknown')
-depends=()
-makedepends=('gcc' 'yasm' 'gcc-libs')
-source=(http://freshgen.googlecode.com/files/mac-3.99-u4-b5.tar.gz
- gcc4_errors.patch)
-md5sums=('75716b342e07deae58f56a2522362006'
- '771c071831871fe8803d139a56515e86')
-
-build() {
- cd ${srcdir}/$pkgname-3.99-u4-b5
- patch -Np1 -i ${srcdir}/gcc4_errors.patch || return 1
- ./configure --prefix=/usr --enable-assembly=yes
- make || return 1
- make DESTDIR=${pkgdir} install
-}
diff --git a/mac/gcc4_errors.patch b/mac/gcc4_errors.patch
deleted file mode 100644
index f7a0898..0000000
--- a/mac/gcc4_errors.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- mac-3.99-u4-b5-s4/src/MACLib/APELink.cpp 2006-06-01 13:00:57.000000000 +0400
-+++ mac-3.99-u4-b5-s4/src/MACLib/APELink.cpp 2009-06-15 00:31:36.081731282 +0400
-@@ -63,10 +63,10 @@
- if (pData != NULL)
- {
- // parse out the information
-- char * pHeader = strstr(pData, APE_LINK_HEADER);
-- char * pImageFile = strstr(pData, APE_LINK_IMAGE_FILE_TAG);
-- char * pStartBlock = strstr(pData, APE_LINK_START_BLOCK_TAG);
-- char * pFinishBlock = strstr(pData, APE_LINK_FINISH_BLOCK_TAG);
-+ const char * pHeader = strstr(pData, APE_LINK_HEADER);
-+ const char * pImageFile = strstr(pData, APE_LINK_IMAGE_FILE_TAG);
-+ const char * pStartBlock = strstr(pData, APE_LINK_START_BLOCK_TAG);
-+ const char * pFinishBlock = strstr(pData, APE_LINK_FINISH_BLOCK_TAG);
-
- if (pHeader && pImageFile && pStartBlock && pFinishBlock)
- {
-@@ -81,7 +81,7 @@
-
- // get the path
- char cImageFile[MAX_PATH + 1]; int nIndex = 0;
-- char * pImageCharacter = &pImageFile[strlen(APE_LINK_IMAGE_FILE_TAG)];
-+ const char * pImageCharacter = &pImageFile[strlen(APE_LINK_IMAGE_FILE_TAG)];
- while ((*pImageCharacter != 0) && (*pImageCharacter != '\r') && (*pImageCharacter != '\n'))
- cImageFile[nIndex++] = *pImageCharacter++;
- cImageFile[nIndex] = 0;