summaryrefslogtreecommitdiffstats
path: root/mplayer-vdpau-nogui/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'mplayer-vdpau-nogui/PKGBUILD')
-rw-r--r--mplayer-vdpau-nogui/PKGBUILD47
1 files changed, 0 insertions, 47 deletions
diff --git a/mplayer-vdpau-nogui/PKGBUILD b/mplayer-vdpau-nogui/PKGBUILD
deleted file mode 100644
index 37c3c83..0000000
--- a/mplayer-vdpau-nogui/PKGBUILD
+++ /dev/null
@@ -1,47 +0,0 @@
-#Contributor: Reiser <metal@pop3.ru>
-
-pkgname=mplayer-vdpau-nogui
-pkgver=30385
-pkgrel=1
-pkgdesc="Famous multimedia player, dev. version, without its GUI and support for nvidia VDPAU"
-arch=('i686' 'x86_64')
-url="http://www.mplayerhq.hu/"
-license=('GPL')
-depends=('ttf-dejavu' 'nvidia>=190.42' 'libvdpau' 'opencore-amr' 'libdvdnav>=4.1.3' 'lame' 'xvidcore')
-makedepends=('subversion')
-conflicts=('mplayer')
-provides=(mplayer=$pkgver)
-source=('no_segfault_configure.diff')
-md5sums=(ed962f7642ffcf2411ec6465fdc8c132)
-
-_svntrunk=svn://svn.mplayerhq.hu/mplayer/trunk
-_svnmod=mplayer-vdpau
-
-build() {
-
- export LDFLAGS="${LDFLAGS//-Wl,--as-needed}"
-
- cd $srcdir
- svn co $_svntrunk $_svnmod
- cp -R $_svnmod $_svnmod-build
- cd $_svnmod-build
- patch -p1 < ../no_segfault_configure.diff
-
- ./configure --prefix=/usr --confdir=/etc/mplayer --disable-gui \
- --disable-runtime-cpudetection --enable-largefiles --enable-menu \
- --disable-libdv --disable-aa --disable-liblzo --disable-speex \
- --disable-fribidi --disable-arts --disable-esd --disable-smb --enable-dvdnav \
- --disable-openal --disable-faad-internal --disable-directfb \
- --disable-musepack --enable-libopencore_amrnb --enable-libopencore_amrwb \
- --enable-vdpau --disable-libbs2b
-
- make || return 1
- make DESTDIR=$pkgdir install || return 1
-
- install -m0644 etc/{codecs.conf,input.conf,example.conf} $pkgdir/etc/mplayer
- install -d $pkgdir/usr/share/mplayer/
- ln -s /usr/share/fonts/TTF/DejaVuSans.ttf $pkgdir/usr/share/mplayer/subfont.ttf
-
- cd ../
- rm -rf ./$_svnmod-build
-}