summaryrefslogtreecommitdiffstats
path: root/mumble
diff options
context:
space:
mode:
Diffstat (limited to 'mumble')
-rw-r--r--mumble/PKGBUILD15
-rw-r--r--mumble/mumble.install37
-rw-r--r--mumble/mumble11x.desktop2
3 files changed, 12 insertions, 42 deletions
diff --git a/mumble/PKGBUILD b/mumble/PKGBUILD
index 5c669ac..8798ded 100644
--- a/mumble/PKGBUILD
+++ b/mumble/PKGBUILD
@@ -6,21 +6,22 @@
# to the depends and delete "no-g15" in the configure line below
pkgname=mumble
-pkgver=1.2.0
-pkgrel=1
+pkgver=1.2.2
+pkgrel=2
arch=('i686' 'x86_64')
pkgdesc="A voice chat application similar to TeamSpeak"
license=('GPL')
-depends=('qt>=4.4.0' 'speex>=1.2rc1' 'celt=>0.7.0' 'lsb-release' 'avahi' 'libsndfile' 'protobuf')
-makedepends=('boost')
+depends=('qt>=4.4.0' 'speex>=1.2rc1' 'celt>=0.7.0' 'lsb-release' 'avahi' 'libsndfile' 'protobuf')
+makedepends=('boost' 'libxi' 'mesa')
optdepends=('pulseaudio: for using mumble with pulseaudio')
conflicts=('mumble-client')
options=('!libtool')
+install=mumble.install
url="http://mumble.sourceforge.net/"
source=("http://downloads.sourceforge.net/mumble/$pkgname-$pkgver.tar.gz" \
- mumble11x.desktop)
-md5sums=('25872328c8bbc8282ad7ebdeacc0e8b6'
- 'b85a15a46a8d0e9a28e87ff6678bb36a')
+ mumble11x.desktop )
+md5sums=('de30ee85170e183b66568b53b04c5727'
+ '70dcaa8ad2ecf68c6ba52ea03d112bcd')
build() {
cd $srcdir/$pkgname-$pkgver
diff --git a/mumble/mumble.install b/mumble/mumble.install
index 7c28ef5..8eea713 100644
--- a/mumble/mumble.install
+++ b/mumble/mumble.install
@@ -1,42 +1,11 @@
-# arg 1: the new package version
-pre_install() {
- /bin/true
-}
-
post_install() {
- echo ' -> Mumble will generate an anonymous usage report'
- echo ' -> 10 minutes after launch. You can deactivate this'
- echo ' -> feature: Menu "Configure" > Settings > User'
- echo ' -> Interface > "Expert Config" > Network > "Submit'
- echo ' -> anonymous statistics"'
- echo ''
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-pre_upgrade() {
- /bin/true
+gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
}
post_upgrade() {
- echo ' -> Mumble will generate an anonymous usage report'
- echo ' -> 10 minutes after launch. You can deactivate this'
- echo ' -> feature: Menu "Configure" > Settings > User'
- echo ' -> Interface > "Expert Config" > Network > "Submit'
- echo ' -> anonymous statistics"'
- echo ''
+post_install
}
-# arg 1: the old package version
-pre_remove() {
- /bin/true
-}
-
-# arg 1: the old package version
post_remove() {
- /bin/true
+post_install
}
-
-op=$1
-shift
-$op $*
diff --git a/mumble/mumble11x.desktop b/mumble/mumble11x.desktop
index 1305f7c..5dba0d0 100644
--- a/mumble/mumble11x.desktop
+++ b/mumble/mumble11x.desktop
@@ -8,4 +8,4 @@ Terminal=false
Type=Application
StartupNotify=false
Categories=Network;Chat;Qt;
-Version=1.0
+Version=1.2.1