summaryrefslogtreecommitdiffstats
path: root/munin-node/Makefile.config
diff options
context:
space:
mode:
Diffstat (limited to 'munin-node/Makefile.config')
-rw-r--r--munin-node/Makefile.config106
1 files changed, 0 insertions, 106 deletions
diff --git a/munin-node/Makefile.config b/munin-node/Makefile.config
deleted file mode 100644
index 9542429..0000000
--- a/munin-node/Makefile.config
+++ /dev/null
@@ -1,106 +0,0 @@
-# This file specifies where Munin will look for things after you've
-# run 'make' in the source directory. Modify it to suit your needs.
-
-# DESTDIR is empty during building, and optionally set to point to
-# a shadow tree during make install.
-
-#
-# the base of the Munin installation.
-#
-PREFIX = $(DESTDIR)
-
-# Where Munin keeps its configurations (server.conf, client.conf, ++)
-CONFDIR = $(DESTDIR)/etc/munin
-
-# Server only - where to put munin-cron
-BINDIR = $(PREFIX)/usr/bin
-
-# Client only - where to put munin-node, munin-node-configure, and munin-run
-SBINDIR = $(PREFIX)/sbin
-
-# Where to put text and html documentation
-DOCDIR = $(PREFIX)/usr/share/doc/munin
-
-# Where to put man pages
-MANDIR = $(PREFIX)/usr/share/man
-
-# Where to put internal binaries and plugin repository
-LIBDIR = $(PREFIX)/usr/lib/munin
-
-# Server only - Output directory
-HTMLDIR = $(PREFIX)/srv/http/munin
-CGIDIR = $(HTMLDIR)/cgi
-
-# Client only - Where to put RRD files and other intenal data
-DBDIR = $(DESTDIR)/var/munin
-
-# Client only - Where plugins should put their states. Must be writable by
-# group "munin", and should be preserved between reboots
-PLUGSTATE = $(DBDIR)/plugin-state
-
-# Where Munin should place its logs.
-LOGDIR = $(DESTDIR)/var/log/munin
-
-# Location of PID files and other statefiles. On the server, must be
-# writable by the user "munin".
-STATEDIR = $(DESTDIR)/var/run/munin
-
-# The perl interpreter to use
-PERL = $(shell which perl)
-
-# The python interpreter to use (used by some plugins)
-PYTHON = /usr/bin/env python
-
-# A modern (posix) shell. We're not looking for arrays, but $() and
-# other modern stuff is expected. On a posix-system the expression
-# below will find the right shell. Most Unixes released the last 10
-# years are POSIX compliant enough for this to work (he said bravely).
-#
-# On Linux /bin/sh, SunOS/Solaris /usr/xpg4/bin/sh or /bin/ksh
-# In general: bash or ksh will work
-#
-GOODSH = $(shell PATH=`getconf PATH` sh -c 'type sh | sed "s/.* //"')
-
-# Path of bash for bash specific plugins
-BASH = /bin/bash
-
-# Server only - Where to install the perl libraries
-PERLLIB = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d"'" -f2)
-
-# Client only - Install plugins for this architecture
-OSTYPE = $(shell uname | tr '[A-Z]' '[a-z]')
-
-# How to figure out the hostname. (Only used in default configuration
-# files)
-HOSTNAME = $(shell hostname)
-
-# What is the safest way to create a tempfile.
-# Default is to figure it out by testing various methods.
-# Replace this with a known platform-specific method
-MKTEMP = $(shell ./test-mktemp)
-
-# Munin version number.
-VERSION = $(shell cat RELEASE)
-
-# User to run munin as
-USER = munin
-GROUP = munin
-
-# Default user to run the plugins as
-PLUGINUSER = nobody
-
-# Which command to use to check if the USER and GROUP to run Munin as, exists.
-GETENT = $(shell which true 2>/dev/null)
-CHECKUSER = $(shell $(GETENT) passwd $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
-CHECKGROUP = $(shell $(GETENT) group $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
-
-# For OSX, comment out the previous two lines and comment in these
-#CHECKUSER = $(shell nicl . -read /users/$(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
-#CHECKGROUP = $(shell nicl . -read /groups/$(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
-
-CHOWN = true
-CHMOD = chmod
-CHGRP = true
-# Check whether setruid functionality can be used
-HASSETR = $(shell perl -e 'use Config; my @vars=("d_setruid", "d_setreuid", "d_setresuid"); foreach my $$var (@vars) { if ($$Config{$$var} eq "define") { print "1\n"; exit 0; } } print "0\n"; exit 0;' )
-