summaryrefslogtreecommitdiffstats
path: root/nettop
diff options
context:
space:
mode:
Diffstat (limited to 'nettop')
-rw-r--r--nettop/PKGBUILD34
-rw-r--r--nettop/nettop-0.2.3-compile.diff41
2 files changed, 0 insertions, 75 deletions
diff --git a/nettop/PKGBUILD b/nettop/PKGBUILD
deleted file mode 100644
index 5fd86ad..0000000
--- a/nettop/PKGBUILD
+++ /dev/null
@@ -1,34 +0,0 @@
-# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
-
-pkgname=nettop
-pkgver=0.2.3
-pkgrel=3
-pkgdesc="A program which looks like top, but is for network packets"
-arch=('i686' 'x86_64')
-url="http://srparish.net/scripts/"
-license=('BSD')
-depends=('slang' 'libpcap')
-makedepends=('patch')
-source=(http://www.sourcefiles.org/Networking/Tools/Scripts/$pkgname-$pkgver.tar.gz \
- $pkgname-$pkgver-compile.diff)
-
-md5sums=('e76602717e79a26b0ab15ab6799fb1ef'
- '49a7768aeb22df656947448b5ef6e734')
-
-build() {
- cd ${srcdir}/$pkgname-$pkgver
- patch -Np0 -i ${srcdir}/$pkgname-$pkgver-compile.diff || return 1
-
- install -d ${pkgdir}/usr/bin \
- ${pkgdir}/usr/share/{doc,licenses}/${pkgname} || return 1
-
- ./configure --prefix=/usr --sysconfdir=/etc/nettop || return 1
- make || return 1
- make prefix=${pkgdir}/usr install || return 1
-
-# License
- cat ${srcdir}/$pkgname-$pkgver/${pkgname}.c | tail -n+3 | head -n26 > \
- ${pkgdir}/usr/share/licenses/$pkgname/LICENSE || return 1
-
- install -D -m644 ChangeLog README THANKS ${pkgdir}/usr/share/doc/${pkgname} || return 1
-}
diff --git a/nettop/nettop-0.2.3-compile.diff b/nettop/nettop-0.2.3-compile.diff
deleted file mode 100644
index 45be973..0000000
--- a/nettop/nettop-0.2.3-compile.diff
+++ /dev/null
@@ -1,41 +0,0 @@
---- nettop.c~ 2001-11-09 04:50:03.000000000 +0100
-+++ nettop.c 2008-05-11 01:52:40.000000000 +0200
-@@ -216,22 +216,26 @@
- }
- }
-
-- ether.count = ether.size = (int) ether.l = (int) ether.r = 0;
-+ ether.count = ether.size = 0;
-+ ether.l = ether.r = NULL;
- ether.type = -1;
- for (i = 0; i < HISTORY_SIZE; i++)
- ether.size_h[i] = 0;
-
-- ip.count = ip.size = (int) ip.l = (int) ip.r = 0;
-+ ip.count = ip.size = 0;
-+ ip.l = ip.r = NULL;
- ip.type = -1;
- for (i = 0; i < HISTORY_SIZE; i++)
- ip.size_h[i] = 0;
-
-- tcp.count = tcp.size = (int) tcp.l = (int) tcp.r = 0;
-+ tcp.count = tcp.size = 0;
-+ tcp.l = tcp.r = NULL;
- tcp.type = -1;
- for (i = 0; i < HISTORY_SIZE; i++)
- tcp.size_h[i] = 0;
-
-- udp.count = udp.size = (int) udp.l = (int) udp.r = 0;
-+ udp.count = udp.size = 0;
-+ udp.l = udp.r = NULL;
- udp.type = -1;
- for (i = 0; i < HISTORY_SIZE; i++)
- udp.size_h[i] = 0;
-@@ -361,6 +365,7 @@
- }
- break;
- default:
-+ break;
- }
- }
- }