summaryrefslogtreecommitdiffstats
path: root/nikto
diff options
context:
space:
mode:
Diffstat (limited to 'nikto')
-rw-r--r--nikto/PKGBUILD25
-rw-r--r--nikto/nikto.install13
-rw-r--r--nikto/nikto.sh4
3 files changed, 0 insertions, 42 deletions
diff --git a/nikto/PKGBUILD b/nikto/PKGBUILD
deleted file mode 100644
index 6b4c282..0000000
--- a/nikto/PKGBUILD
+++ /dev/null
@@ -1,25 +0,0 @@
-# Maintainer: Arkham <arkham at archlinux dot us>
-# Contributor: Arkham <arkham at archlinux dot us>
-
-pkgname=nikto
-pkgver=2.1.1
-pkgrel=1
-pkgdesc='A web server scanner which performs comprehensive tests against web servers for multiple items'
-url='http://www.cirt.net/code/nikto.shtml'
-license=('GPL')
-arch=('any')
-depends=('perl' 'openssl' 'perl-net-ssleay')
-install=$pkgname.install
-source=(http://www.cirt.net/nikto/$pkgname-$pkgver.tar.gz
- nikto.sh)
-md5sums=('a9404c3f464b08f3f48788d5f39e0ca7'
- 'eb7b704c8bdae28af9a0353764d0b552')
-
-build() {
- cd $srcdir/$pkgname-$pkgver
-
- install -d $pkgdir/usr/share/nikto
- cp -a * $pkgdir/usr/share/nikto/
- find $pkgdir/usr/share/nikto -type f -exec chmod 644 {} +
- install -Dm 755 $srcdir/nikto.sh $pkgdir/usr/bin/nikto
-}
diff --git a/nikto/nikto.install b/nikto/nikto.install
deleted file mode 100644
index aefdd93..0000000
--- a/nikto/nikto.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- echo "> Don't forget to update your plugins running as root:"
- echo "> nikto -update"
- echo ""
-}
-
-post_upgrade() {
- post_install $1
-}
-
-pre_remove() {
- /bin/true
-}
diff --git a/nikto/nikto.sh b/nikto/nikto.sh
deleted file mode 100644
index 8d36d2a..0000000
--- a/nikto/nikto.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/bash
-
-cd /usr/share/nikto
-perl nikto.pl $@