summaryrefslogtreecommitdiffstats
path: root/oss-mercurial/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'oss-mercurial/PKGBUILD')
-rw-r--r--oss-mercurial/PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/oss-mercurial/PKGBUILD b/oss-mercurial/PKGBUILD
index ff4a285..c455701 100644
--- a/oss-mercurial/PKGBUILD
+++ b/oss-mercurial/PKGBUILD
@@ -1,7 +1,7 @@
# This is a modified version of the oss pkg in community
pkgname="oss-mercurial"
-pkgver="4.2"
-pkgrel=1
+pkgver="4.1"
+pkgrel=3
pkgdesc="Open Sound System UNIX audio architecture"
arch=('i686' 'x86_64')
url="http://developer.opensound.com/"
@@ -17,7 +17,10 @@ md5sums=('b9a380a0ac8896390d71ac13676f27e1'
'1494a2304a1eb7a1979e7e83d894c67a')
optdepends=('gtk2: for graphical mixer (ossxmix)'
- 'hal: for automatic USB audio configuration')
+ 'hal: for automatic USB audio configuration'
+ 'libflashsupport-oss: for Flash plugin support')
+
+[ "$CARCH" = "x86_64" ] && optdepends[2]='lib32-libflashsupport-oss: for Flash plugin support'
build() {
#_dir="oss-v4.1-buildrc2-src-gpl"
@@ -31,7 +34,11 @@ build() {
unset OSFLAGS
unset LIBRARIES
+ # Remove libflashsupport, as it belongs to a separate package.
+ rm -f "$srcdir/$_dir/oss/lib/flashsupport.c" &> /dev/null
+
msg "Preparing the build environment."
+ zsh
if [ ! -d build ]; then
# Create build directory and configure