summaryrefslogtreecommitdiffstats
path: root/oss-mercurial/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'oss-mercurial/PKGBUILD')
-rw-r--r--oss-mercurial/PKGBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/oss-mercurial/PKGBUILD b/oss-mercurial/PKGBUILD
new file mode 100644
index 0000000..daea34a
--- /dev/null
+++ b/oss-mercurial/PKGBUILD
@@ -0,0 +1,59 @@
+# This is a modified version of the oss pkg in community
+pkgname="oss-mercurial"
+pkgver="4.1"
+pkgrel=3
+pkgdesc="Open Sound System UNIX audio architecture"
+arch=('i686' 'x86_64')
+url="http://developer.opensound.com/"
+license=('GPL2')
+depends=('gcc' 'make' 'kernel-headers' 'module-init-tools' 'libtool' 'sed')
+makedepends=('pkgconfig' 'gawk' 'gtk2' 'mercurial')
+provides=('oss')
+conflicts=('oss-linux' 'oss-linux-free' 'oss-testing' 'oss')
+install='oss.install'
+source=('oss.rm-init-scripts.patch' 'oss.rc' 'oss.install')
+md5sums=('b9a380a0ac8896390d71ac13676f27e1'
+ '8ca7cdf94c56ab02890eb4aba6a4995f'
+ '1494a2304a1eb7a1979e7e83d894c67a')
+
+optdepends=('gtk2: for graphical mixer (ossxmix)'
+ 'hal: for automatic USB audio configuration')
+
+build() {
+ #_dir="oss-v4.1-buildrc2-src-gpl"
+ _dir="mercurial.opensound.com"
+
+ cd "$srcdir"
+ hg clone http://mercurial.opensound.com
+
+ # Avoid these flags conflicting with OSS build system.
+ unset CFLAGS
+ unset OSFLAGS
+ unset LIBRARIES
+
+ msg "Preparing the build environment."
+
+ if [ ! -d build ]; then
+ # Create build directory and configure
+ mkdir build && cd build
+ "$srcdir/$_dir/configure" --enable-libsalsa=NO || return 1
+ else
+ # Change to existing build directory
+ cd build
+ fi
+
+ msg "Building OSS."
+ make build || return 1
+
+ msg "Patching init scripts."
+ cd "$srcdir/build/prototype"
+ rm usr/lib/oss/etc/S89oss
+ patch -b -p0 < "$srcdir/oss.rm-init-scripts.patch" || return 1
+
+ msg "Copying files."
+ cp -R * "$pkgdir"
+ chmod 755 "$pkgdir/usr/sbin/" "$pkgdir/usr/lib/oss/etc/" "$pkgdir/usr/lib/oss/build/"
+ install -D -m755 "$srcdir/oss.rc" "$pkgdir/etc/rc.d/oss"
+
+}
+