summaryrefslogtreecommitdiffstats
path: root/oss-mercurial/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'oss-mercurial/PKGBUILD')
-rw-r--r--oss-mercurial/PKGBUILD67
1 files changed, 0 insertions, 67 deletions
diff --git a/oss-mercurial/PKGBUILD b/oss-mercurial/PKGBUILD
deleted file mode 100644
index c53e5b7..0000000
--- a/oss-mercurial/PKGBUILD
+++ /dev/null
@@ -1,67 +0,0 @@
-# This is a modified version of the oss pkg in community
-pkgname="oss-mercurial"
-pkgver="4.1"
-pkgrel=`date +%Y_%m_%d_%T`
-pkgdesc="Open Sound System UNIX audio architecture"
-arch=('i686' 'x86_64')
-url="http://developer.opensound.com/"
-license=('GPL2')
-depends=('gcc' 'make' 'kernel-headers' 'module-init-tools' 'libtool' 'sed')
-makedepends=('pkgconfig' 'gawk' 'gtk2' 'mercurial')
-provides=('oss')
-conflicts=('oss-linux' 'oss-linux-free' 'oss-testing' 'oss')
-install='oss.install'
-source=('oss.rm-init-scripts.patch' 'oss.rc' 'oss.install')
-md5sums=('b9a380a0ac8896390d71ac13676f27e1'
- '8ca7cdf94c56ab02890eb4aba6a4995f'
- '1494a2304a1eb7a1979e7e83d894c67a')
-
-optdepends=('gtk2: for graphical mixer (ossxmix)'
- 'hal: for automatic USB audio configuration'
- 'libflashsupport-oss: for Flash plugin support')
-
-[ "$CARCH" = "x86_64" ] && optdepends[2]='lib32-libflashsupport-oss: for Flash plugin support'
-
-build() {
- #_dir="oss-v4.1-buildrc2-src-gpl"
- _dir="oss-hg-src"
-
- cd "$srcdir"
- hg clone http://opensound.hg.sourceforge.net/hgweb/opensound $_dir
-
- # Avoid these flags conflicting with OSS build system.
- unset CFLAGS
- unset OSFLAGS
- unset LIBRARIES
-
- # Remove libflashsupport, as it belongs to a separate package.
- rm -f "$srcdir/$_dir/oss/lib/flashsupport.c" &> /dev/null
-
- msg "Preparing the build environment."
- zsh
-
- if [ ! -d build ]; then
- # Create build directory and configure
- mkdir build && cd build
- "$srcdir/$_dir/configure" --enable-libsalsa=NO || return 1
- else
- # Change to existing build directory
- cd build
- fi
-
- msg "Building OSS."
- make build || return 1
-
- msg "Patching init scripts."
- cd "$srcdir/build/prototype"
- rm usr/lib/oss/etc/S89oss
- patch -b -p0 < "$srcdir/oss.rm-init-scripts.patch" || return 1
-
- msg "Copying files."
- cp -R * "$pkgdir"
- chmod 755 "$pkgdir/usr/sbin/" "$pkgdir/usr/lib/oss/etc/" "$pkgdir/usr/lib/oss/build/"
- install -D -m755 "$srcdir/oss.rc" "$pkgdir/etc/rc.d/oss"
-
-}
-
-# vim: set ft=zsh: