summaryrefslogtreecommitdiffstats
path: root/pacman-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pacman-git/PKGBUILD')
-rw-r--r--pacman-git/PKGBUILD96
1 files changed, 96 insertions, 0 deletions
diff --git a/pacman-git/PKGBUILD b/pacman-git/PKGBUILD
new file mode 100644
index 0000000..2a95d09
--- /dev/null
+++ b/pacman-git/PKGBUILD
@@ -0,0 +1,96 @@
+# Maintainer: Dave Reisner <d@falconindy.com>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: godane <slaxemulator@gmail.com.com>
+# Contributor: Andres Perera <aepd87@gmail.com>
+
+pkgname=pacman-git
+pkgver=20110112
+pkgrel=1
+pkgdesc="A library-based package manager with dependency support. git version."
+arch=('i686' 'x86_64')
+url="http://www.archlinux.org/pacman/"
+license=('GPL')
+groups=('base')
+depends=('bash' 'libarchive>=2.7.1' 'libfetch>=2.25' 'pacman-mirrorlist')
+makedepends=('git' 'asciidoc')
+optdepends=('fakeroot: for makepkg usage as normal user'
+ 'curl: for rankmirrors usage')
+backup=(etc/pacman.conf etc/makepkg.conf)
+conflicts=('pacman')
+provides=('pacman')
+options=(!libtool)
+source=(pacman.conf
+ pacman.conf.x86_64
+ makepkg.conf)
+md5sums=('eda9cbdb47f85fabda2e7e63801e3e16'
+ '9ba146b4fa7bcb3cc18204b06d1f6157'
+ 'aef317285c7d16ac495b0e53deeb948d')
+
+_gitroot="git://projects.archlinux.org/pacman.git"
+_gitname="pacman"
+
+build() {
+ msg 'Connecting to GIT server...'
+
+ if [[ -d $_gitname ]]; then
+ ( cd $_gitname && git pull origin )
+ msg 'The local files are updated.'
+ else
+ git clone $_gitroot
+ fi
+
+ msg 'GIT checkout done or server timeout'
+ msg 'Starting make...'
+
+ rm -rf $_gitname-build
+ git clone $_gitname{,-build}
+ cd $_gitname-build
+
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-doc \
+ --enable-git-version
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+
+ make DESTDIR=$pkgdir install
+
+ # install Arch specific stuff
+ mkdir -p $pkgdir/etc
+ case "$CARCH" in
+ i686)
+ install -m644 $srcdir/pacman.conf $pkgdir/etc/pacman.conf
+ ;;
+ x86_64)
+ install -m644 $srcdir/pacman.conf.x86_64 $pkgdir/etc/pacman.conf
+ ;;
+ esac
+ install -m644 $srcdir/makepkg.conf $pkgdir/etc/
+ # set things correctly in the default conf file
+ case "$CARCH" in
+ i686)
+ mycarch="i686"
+ mychost="i686-pc-linux-gnu"
+ myflags="-march=i686 "
+ ;;
+ x86_64)
+ mycarch="x86_64"
+ mychost="x86_64-unknown-linux-gnu"
+ myflags="-march=x86-64 "
+ ;;
+ esac
+ sed -i $pkgdir/etc/makepkg.conf \
+ -e "s|@CARCH[@]|$mycarch|g" \
+ -e "s|@CHOST[@]|$mychost|g" \
+ -e "s|@CARCHFLAGS[@]|$myflags|g"
+
+ # install completion files
+ mkdir -p $pkgdir/etc/bash_completion.d/
+ install -m644 contrib/bash_completion $pkgdir/etc/bash_completion.d/pacman
+ mkdir -p $pkgdir/usr/share/zsh/site-functions/
+ install -m644 contrib/zsh_completion $pkgdir/usr/share/zsh/site-functions/_pacman
+}
+
+# vim: set ts=2 sw=2 et: