summaryrefslogtreecommitdiffstats
path: root/pacman-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'pacman-git/PKGBUILD')
-rw-r--r--pacman-git/PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/pacman-git/PKGBUILD b/pacman-git/PKGBUILD
index 2a95d09..51d9187 100644
--- a/pacman-git/PKGBUILD
+++ b/pacman-git/PKGBUILD
@@ -4,27 +4,26 @@
# Contributor: Andres Perera <aepd87@gmail.com>
pkgname=pacman-git
-pkgver=20110112
+pkgver=20110428
pkgrel=1
pkgdesc="A library-based package manager with dependency support. git version."
arch=('i686' 'x86_64')
url="http://www.archlinux.org/pacman/"
license=('GPL')
groups=('base')
-depends=('bash' 'libarchive>=2.7.1' 'libfetch>=2.25' 'pacman-mirrorlist')
+depends=('bash' 'curl>=7.19.4' 'gpgme' 'libarchive>=2.7.1' 'pacman-mirrorlist')
makedepends=('git' 'asciidoc')
-optdepends=('fakeroot: for makepkg usage as normal user'
- 'curl: for rankmirrors usage')
+optdepends=('fakeroot: for makepkg usage as normal user')
backup=(etc/pacman.conf etc/makepkg.conf)
conflicts=('pacman')
provides=('pacman')
-options=(!libtool)
+options=(!libtool !strip)
source=(pacman.conf
pacman.conf.x86_64
makepkg.conf)
-md5sums=('eda9cbdb47f85fabda2e7e63801e3e16'
- '9ba146b4fa7bcb3cc18204b06d1f6157'
- 'aef317285c7d16ac495b0e53deeb948d')
+md5sums=('10c2b220d4d2ec37a54ab7d8982acdd2'
+ 'c6559dc43140e9023041171e72bd91e8'
+ 'a7be38e9fcf92414ded8c7f9574a5a9b')
_gitroot="git://projects.archlinux.org/pacman.git"
_gitname="pacman"
@@ -48,10 +47,16 @@ build() {
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --enable-doc \
- --enable-git-version
+ --enable-git-version --enable-debug
make
}
+check() {
+ cd "$srcdir/$_gitname-build"
+
+ make check
+}
+
package() {
cd "$srcdir/$_gitname-build"