summaryrefslogtreecommitdiffstats
path: root/perl-class-inspector/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'perl-class-inspector/PKGBUILD')
-rw-r--r--perl-class-inspector/PKGBUILD54
1 files changed, 0 insertions, 54 deletions
diff --git a/perl-class-inspector/PKGBUILD b/perl-class-inspector/PKGBUILD
deleted file mode 100644
index a4ffbd7..0000000
--- a/perl-class-inspector/PKGBUILD
+++ /dev/null
@@ -1,54 +0,0 @@
-# PKGBUILD generated by pacpan
-pkgname=perl-class-inspector
-_realname=Class-Inspector
-pkgver=1.24
-pkgrel=1
-pkgdesc="'Get information about a class and its structure'"
-arch=(i686 x86_64)
-license=('perl')
-url="http://search.cpan.org/~adamk/Class-Inspector"
-options=(!emptydirs)
-
-depends=('perl>=5.10.1')
-makedepends=('perl')
-
-#provides=('Class-Inspector')
-provides=('class-inspector=1.24' 'Class::Inspector=1.24' 'perl-class-inspector=1.24' 'Class::Inspector::Functions=1.24' 'perl-class-inspector-functions=1.24')
-
-source=(http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Class-Inspector-1.24.tar.gz)
-md5sums=('609189b49f64d329a6e413e0a6d8724a')
-
-build() {
- _expected_dir="${srcdir}/${_realname}-${pkgver}"
- if [ -d "$_expected_dir" ]; then
- cd "$_expected_dir"
- else
- _expected_dir="${srcdir}/$(bsdtar -t -f $(basename $source) | head -n1)"
- if [ -d "$_expected_dir" ]; then
- cd "$_expected_dir"
- else
- _makefile=$(find $srcdir -iname Makefile.PL)
- if [ ! -z "$_makefile" ]; then
- _expected_dir=$(dirname $_makefile)
- if [ -d "$_expected_dir" ]; then
- cd "$_expected_dir"
- else
- echo "ERROR unable to detect source directory"
- echo "--> this is often due to CPAN's lack of standard naming conventions"
- echo "--> it may be possible to fix this by adjusting the build function in the PKGBUILD"
- fi
- fi
- fi
- fi
- # install module in vendor directories.
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make install DESTDIR=${pkgdir} || return 1
-
- # remove perllocal.pod and .packlist
- find ${pkgdir} -name perllocal.pod -delete
- find ${pkgdir} -name .packlist -delete
-}
-
-# vim:set ts=2 sw=2 et:
-