summaryrefslogtreecommitdiffstats
path: root/portbunny/installpath.patch
diff options
context:
space:
mode:
Diffstat (limited to 'portbunny/installpath.patch')
-rw-r--r--portbunny/installpath.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/portbunny/installpath.patch b/portbunny/installpath.patch
new file mode 100644
index 0000000..96b12ef
--- /dev/null
+++ b/portbunny/installpath.patch
@@ -0,0 +1,59 @@
+diff -Nur PortBunny050109-dev/Makefile PortBunny050109-dev-arch/Makefile
+--- PortBunny050109-dev/Makefile 2009-01-05 14:21:47.000000000 +0100
++++ PortBunny050109-dev-arch/Makefile 2009-01-14 22:38:49.300678488 +0100
+@@ -49,5 +49,5 @@
+
+ install:
+
+- $(shell install -m 644 portbunny.ko /lib/modules/$(shell uname -r)/kernel/portbunny.ko; /sbin/depmod -a)
+- $(shell cp -r ./UI/* /usr/local/)
++ install -m 644 portbunny.ko ${DESTDIR}/lib/modules/$(shell uname -r)/kernel/portbunny.ko
++ cp -r ./UI/* ${DESTDIR}/usr/
+diff -Nur PortBunny050109-dev/UI/bin/portbunny PortBunny050109-dev-arch/UI/bin/portbunny
+--- PortBunny050109-dev/UI/bin/portbunny 2008-10-26 08:41:32.000000000 +0100
++++ PortBunny050109-dev-arch/UI/bin/portbunny 2009-01-14 22:38:13.567338951 +0100
+@@ -12,7 +12,7 @@
+
+
+ PBUNNY_SHARE = '../share/portbunny/'
+-PBUNNY_SHARE2 = '/usr/local/share/portbunny/'
++PBUNNY_SHARE2 = '/usr/share/portbunny/'
+
+ import sys
+ import time
+diff -Nur PortBunny050109-dev/UI/bin/portbunny.py PortBunny050109-dev-arch/UI/bin/portbunny.py
+--- PortBunny050109-dev/UI/bin/portbunny.py 2008-10-26 08:41:32.000000000 +0100
++++ PortBunny050109-dev-arch/UI/bin/portbunny.py 2009-01-14 22:38:13.567338951 +0100
+@@ -12,7 +12,7 @@
+
+
+ PBUNNY_SHARE = '../share/portbunny/'
+-PBUNNY_SHARE2 = '/usr/local/share/portbunny/'
++PBUNNY_SHARE2 = '/usr/share/portbunny/'
+
+ import sys
+ import time
+diff -Nur PortBunny050109-dev/UI/share/portbunny/PBunnyServices.py PortBunny050109-dev-arch/UI/share/portbunny/PBunnyServices.py
+--- PortBunny050109-dev/UI/share/portbunny/PBunnyServices.py 2008-10-26 08:41:32.000000000 +0100
++++ PortBunny050109-dev-arch/UI/share/portbunny/PBunnyServices.py 2009-01-14 22:38:25.061728150 +0100
+@@ -7,7 +7,7 @@
+
+ ETC_SERVICES = '../share/portbunny/services'
+ if not os.path.exists(ETC_SERVICES):
+- ETC_SERVICES = '/usr/local/share/portbunny/services'
++ ETC_SERVICES = '/usr/share/portbunny/services'
+
+
+ """
+diff -Nur PortBunny050109-dev/scanner_ui/scanner_ui.c PortBunny050109-dev-arch/scanner_ui/scanner_ui.c
+--- PortBunny050109-dev/scanner_ui/scanner_ui.c 2008-10-26 08:41:30.000000000 +0100
++++ PortBunny050109-dev-arch/scanner_ui/scanner_ui.c 2009-01-14 22:37:59.164038548 +0100
+@@ -344,7 +344,7 @@
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,12)
+
+ #if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,25)
+- device_create_drvdata(portbunny_class, NULL, MKDEV(major, 0), NULL, "portbunny");
++ device_create(portbunny_class, NULL, MKDEV(major, 0), NULL, "portbunny");
+ #else
+ class_device_create(portbunny_class, NULL, MKDEV(major, 0), NULL, "portbunny");
+ #endif