summaryrefslogtreecommitdiffstats
path: root/portbunny
diff options
context:
space:
mode:
Diffstat (limited to 'portbunny')
-rw-r--r--portbunny/PKGBUILD31
-rw-r--r--portbunny/installpath.patch59
-rw-r--r--portbunny/portbunny.install20
-rw-r--r--portbunny/timespec.patch20
4 files changed, 0 insertions, 130 deletions
diff --git a/portbunny/PKGBUILD b/portbunny/PKGBUILD
deleted file mode 100644
index 0b16e91..0000000
--- a/portbunny/PKGBUILD
+++ /dev/null
@@ -1,31 +0,0 @@
-# Maintainer: Florian Pritz <f-p@gmx.at>
-# Contributor: Martijn F. Arts <mfa@devtty0.de>
-
-pkgname=portbunny
-pkgver="050109_dev"
-pkgrel=1
-pkgdesc="A fast TCP-SYN Linux-kernel-based port-scanner"
-arch=('i686' 'x86_64')
-url="http://www.recurity-labs.com/portbunny/"
-license=('GPL')
-depends=('python>=2.4')
-makedepends=('make' 'gcc' 'kernel-headers')
-install=portbunny.install
-source=("http://portbunny.recurity.com/tarballs/PortBunny050109-dev.tar.gz" "installpath.patch" "timespec.patch")
-build() {
- cd "$startdir/src/PortBunny050109-dev"
- patch -p1 < $srcdir/installpath.patch
- patch -p1 < $srcdir/timespec.patch
- make
- mkdir -p $pkgdir/lib/modules/$(uname -r)/kernel/ $pkgdir/usr/share/portbunny
- mkdir -p $pkgdir/usr/bin
- DESTDIR="$pkgdir" make install
-}
-
-# vim:set ts=2 sw=2 et:
-md5sums=('792ceed6d20e5035f9dc1fcc318d2bbe'
- 'd056310ab5b14b6f859907b6fac7ae5d'
- '4c1d452b454d78d36ce90f60a6c7ce90')
-sha1sums=('829a3c39bc021d81c600899cd4b25de2f01cce32'
- 'd765395cda24edea41c66d213b14973a62e88e48'
- '8f4f93aeab397f39e5408d6090d34af73330c09c')
diff --git a/portbunny/installpath.patch b/portbunny/installpath.patch
deleted file mode 100644
index 96b12ef..0000000
--- a/portbunny/installpath.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-diff -Nur PortBunny050109-dev/Makefile PortBunny050109-dev-arch/Makefile
---- PortBunny050109-dev/Makefile 2009-01-05 14:21:47.000000000 +0100
-+++ PortBunny050109-dev-arch/Makefile 2009-01-14 22:38:49.300678488 +0100
-@@ -49,5 +49,5 @@
-
- install:
-
-- $(shell install -m 644 portbunny.ko /lib/modules/$(shell uname -r)/kernel/portbunny.ko; /sbin/depmod -a)
-- $(shell cp -r ./UI/* /usr/local/)
-+ install -m 644 portbunny.ko ${DESTDIR}/lib/modules/$(shell uname -r)/kernel/portbunny.ko
-+ cp -r ./UI/* ${DESTDIR}/usr/
-diff -Nur PortBunny050109-dev/UI/bin/portbunny PortBunny050109-dev-arch/UI/bin/portbunny
---- PortBunny050109-dev/UI/bin/portbunny 2008-10-26 08:41:32.000000000 +0100
-+++ PortBunny050109-dev-arch/UI/bin/portbunny 2009-01-14 22:38:13.567338951 +0100
-@@ -12,7 +12,7 @@
-
-
- PBUNNY_SHARE = '../share/portbunny/'
--PBUNNY_SHARE2 = '/usr/local/share/portbunny/'
-+PBUNNY_SHARE2 = '/usr/share/portbunny/'
-
- import sys
- import time
-diff -Nur PortBunny050109-dev/UI/bin/portbunny.py PortBunny050109-dev-arch/UI/bin/portbunny.py
---- PortBunny050109-dev/UI/bin/portbunny.py 2008-10-26 08:41:32.000000000 +0100
-+++ PortBunny050109-dev-arch/UI/bin/portbunny.py 2009-01-14 22:38:13.567338951 +0100
-@@ -12,7 +12,7 @@
-
-
- PBUNNY_SHARE = '../share/portbunny/'
--PBUNNY_SHARE2 = '/usr/local/share/portbunny/'
-+PBUNNY_SHARE2 = '/usr/share/portbunny/'
-
- import sys
- import time
-diff -Nur PortBunny050109-dev/UI/share/portbunny/PBunnyServices.py PortBunny050109-dev-arch/UI/share/portbunny/PBunnyServices.py
---- PortBunny050109-dev/UI/share/portbunny/PBunnyServices.py 2008-10-26 08:41:32.000000000 +0100
-+++ PortBunny050109-dev-arch/UI/share/portbunny/PBunnyServices.py 2009-01-14 22:38:25.061728150 +0100
-@@ -7,7 +7,7 @@
-
- ETC_SERVICES = '../share/portbunny/services'
- if not os.path.exists(ETC_SERVICES):
-- ETC_SERVICES = '/usr/local/share/portbunny/services'
-+ ETC_SERVICES = '/usr/share/portbunny/services'
-
-
- """
-diff -Nur PortBunny050109-dev/scanner_ui/scanner_ui.c PortBunny050109-dev-arch/scanner_ui/scanner_ui.c
---- PortBunny050109-dev/scanner_ui/scanner_ui.c 2008-10-26 08:41:30.000000000 +0100
-+++ PortBunny050109-dev-arch/scanner_ui/scanner_ui.c 2009-01-14 22:37:59.164038548 +0100
-@@ -344,7 +344,7 @@
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,12)
-
- #if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,25)
-- device_create_drvdata(portbunny_class, NULL, MKDEV(major, 0), NULL, "portbunny");
-+ device_create(portbunny_class, NULL, MKDEV(major, 0), NULL, "portbunny");
- #else
- class_device_create(portbunny_class, NULL, MKDEV(major, 0), NULL, "portbunny");
- #endif
diff --git a/portbunny/portbunny.install b/portbunny/portbunny.install
deleted file mode 100644
index f923755..0000000
--- a/portbunny/portbunny.install
+++ /dev/null
@@ -1,20 +0,0 @@
-# arg 1: the new package version
-post_install() {
- /sbin/depmod -a
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- /sbin/depmod -a
-}
-
-post_remove() {
- /sbin/depmod -a
-}
-
-op=$1
-shift
-[ "$(type -t "$op")" = "function" ] && $op "$@"
-
-# vim:set ts=2 sw=2 et:
diff --git a/portbunny/timespec.patch b/portbunny/timespec.patch
deleted file mode 100644
index 6ac01ae..0000000
--- a/portbunny/timespec.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- PortBunny050109-dev/timespec_utils.c 2008-10-26 08:41:32.000000000 +0100
-+++ PortBunny050109-dev/timespec_utils.c.new 2010-01-08 13:08:48.000000000 +0100
-@@ -53,7 +53,7 @@
-
-
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,16)
--
-+#if false
- void set_normalized_timespec(struct timespec *ts, time_t sec, long nsec)
- {
- while (nsec >= NSEC_PER_SEC) {
-@@ -67,7 +67,7 @@
- ts->tv_sec = sec;
- ts->tv_nsec = nsec;
- }
--
-+#endif
- #endif
-
-