summaryrefslogtreecommitdiffstats
path: root/rtorrent-color/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'rtorrent-color/PKGBUILD')
-rw-r--r--rtorrent-color/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/rtorrent-color/PKGBUILD b/rtorrent-color/PKGBUILD
new file mode 100644
index 0000000..d44c680
--- /dev/null
+++ b/rtorrent-color/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ashren <edgar [at] archlinux [dot] us>
+
+pkgname=rtorrent-color
+pkgver=0.8.6
+pkgrel=5
+pkgdesc="Ncurses BitTorrent client based on libTorrent with color patch."
+arch=('i686' 'x86_64')
+url="http://libtorrent.rakshasa.no"
+install=$pkgname.install
+license=('GPL')
+depends=('libtorrent=0.12.6' 'curl>=7.14.3' 'xmlrpc-c')
+source=(http://libtorrent.rakshasa.no/downloads/rtorrent-$pkgver.tar.gz rtorrent-0.8.6-canvas-fix.patch)
+conflicts=('rtorrent')
+
+md5sums=('b804c45c01c40312926bcea6b55bb084'
+ '03cbbf61ac0c5a128880a5a453677a87')
+
+build() {
+ cd "$srcdir/rtorrent-$pkgver"
+ patch -p1 < $startdir/src/rtorrent-0.8.6-canvas-fix.patch
+ CXXFLAGS="$CXXFLAGS -fno-strict-aliasing" \
+ ./configure --prefix=/usr --disable-debug --with-xmlrpc-c || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+
+# vim:set ts=2 sw=2 et: