summaryrefslogtreecommitdiffstats
path: root/rxvt-unicode-256color
diff options
context:
space:
mode:
Diffstat (limited to 'rxvt-unicode-256color')
-rw-r--r--rxvt-unicode-256color/PKGBUILD65
-rw-r--r--rxvt-unicode-256color/font-width-fix.patch26
-rw-r--r--rxvt-unicode-256color/gcc4.4.patch22
-rw-r--r--rxvt-unicode-256color/rxvt-unicode.desktop9
-rw-r--r--rxvt-unicode-256color/rxvt-unicode.pngbin1513 -> 0 bytes
5 files changed, 0 insertions, 122 deletions
diff --git a/rxvt-unicode-256color/PKGBUILD b/rxvt-unicode-256color/PKGBUILD
deleted file mode 100644
index 2acebb0..0000000
--- a/rxvt-unicode-256color/PKGBUILD
+++ /dev/null
@@ -1,65 +0,0 @@
-# Contributor: tobias <tobias@archlinux.org>
-# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
-# Contributer: N30N <archlinux@alunamation.com>
-# Contributor: Florian Pritz <f-p@gmx.at>
-# Contributor: RayNbow <ShinNoNoir@gmail.com>
-# Contributor: Oliver Mader <dotb52@gmail.com>
-
-pkgname="rxvt-unicode-256color"
-pkgver=9.06
-pkgrel=3
-pkgdesc="a unicode enabled rxvt-clone terminal emulator (urxvt), with 256 colour support"
-arch=("i686" "x86_64")
-depends=("gcc-libs" "libxft")
-makedepends=("ncurses" "perl" "pkgconfig")
-optdepends=("gtk2-perl: for urxvt-tabbed usage")
-url="http://software.schmorp.de/pkg/rxvt-unicode.html"
-license=("GPL2")
-source=("rxvt-unicode.desktop" \
- "rxvt-unicode.png" \
- "font-width-fix.patch" \
- "gcc4.4.patch" \
- http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-${pkgver}.tar.bz2)
-md5sums=("ef2dfa44a86cae36a60f45559d8ad783" \
- "84328cada91751df07324d95f8be4d1b" \
- "df0c3a8b6bb0578d1b91e4081c47881c"
- "1b9b112df2204e1e58c66bf2d5776422" \
- "4cb9330e99fc0b0b05cebf3581557dd8")
-provides=("rxvt-unicode")
-conflicts=("rxvt-unicode")
-replaces=("rxvt-unicode-256color-fontfix")
-
-build() {
- cd ${srcdir}/rxvt-unicode-${pkgver}
-
- # Add 256 color support
- patch -p1 -i doc/urxvt-8.2-256color.patch || return 1
-
- # Fix font width bug fix
- patch -p0 -i ${srcdir}/font-width-fix.patch || return 1
-
- # Port to compile with GCC4.4
- patch -p0 -i ${srcdir}/gcc4.4.patch || return 1
-
- ./configure --prefix=/usr \
- --with-terminfo=/usr/share/terminfo \
- --with-term=rxvt-256color \
- --enable-smart-resize \
- --disable-iso14755
-
- msg "Starting build process."
- make || return 1
- install -d ${pkgdir}/usr/share/terminfo
- TERMINFO=${pkgdir}/usr/share/terminfo
- make DESTDIR=${pkgdir} install
-
- # install the tabbing wrapper
- sed -i 's/\"rxvt\"/"urxvt"/' doc/rxvt-tabbed
- install -D -m755 doc/rxvt-tabbed ${startdir}/pkg/usr/bin/urxvt-tabbed
-
- # install freedesktop menu and icon ( icon from cvs checkout )
- install -D -m644 ${srcdir}/rxvt-unicode.desktop \
- ${pkgdir}/usr/share/applications/rxvt-unicode.desktop
- install -Dm644 ${srcdir}/rxvt-unicode.png \
- ${pkgdir}/usr/share/pixmaps/rxvt-unicode.png
-}
diff --git a/rxvt-unicode-256color/font-width-fix.patch b/rxvt-unicode-256color/font-width-fix.patch
deleted file mode 100644
index 811d9e6..0000000
--- a/rxvt-unicode-256color/font-width-fix.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/rxvtfont.C.bukind 2007-11-30 14:36:33.000000000 +0600
-+++ src/rxvtfont.C 2007-11-30 14:39:29.000000000 +0600
-@@ -1171,12 +1171,21 @@
- XGlyphInfo g;
- XftTextExtents16 (disp, f, &ch, 1, &g);
-
-+/*
-+ * bukind: don't use g.width as a width of a character!
-+ * instead use g.xOff, see e.g.: http://keithp.com/~keithp/render/Xft.tutorial
-+
- g.width -= g.x;
-
- int wcw = WCWIDTH (ch);
- if (wcw > 0) g.width = (g.width + wcw - 1) / wcw;
-
- if (width < g.width ) width = g.width;
-+ */
-+ int wcw = WCWIDTH (ch);
-+ if (wcw > 1) g.xOff = g.xOff / wcw;
-+ if (width < g.xOff) width = g.xOff;
-+
- if (height < g.height ) height = g.height;
- if (glheight < g.height - g.y) glheight = g.height - g.y;
- }
-
-
diff --git a/rxvt-unicode-256color/gcc4.4.patch b/rxvt-unicode-256color/gcc4.4.patch
deleted file mode 100644
index b854a1f..0000000
--- a/rxvt-unicode-256color/gcc4.4.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/command.C.old 2009-05-28 15:21:04.457772957 +0200
-+++ src/command.C 2009-05-28 15:18:52.684597530 +0200
-@@ -3336,7 +3336,7 @@
- }
- else
- {
-- char *eq = strchr (str, '='); // constness lost, but verified to be ok
-+ char *eq = (char *) strchr ( str, '='); // constness lost, but verified to be ok
-
- if (eq)
- {
---- src/misc.C.old 2009-05-28 15:21:16.400270603 +0200
-+++ src/misc.C 2009-05-28 15:21:51.697108339 +0200
-@@ -170,7 +170,7 @@
- char *
- rxvt_basename (const char *str) NOTHROW
- {
-- char *base = strrchr (str, '/');
-+ char *base = (char *) strrchr (str, '/');
-
- return (char *) (base ? base + 1 : str);
- }
diff --git a/rxvt-unicode-256color/rxvt-unicode.desktop b/rxvt-unicode-256color/rxvt-unicode.desktop
deleted file mode 100644
index c616994..0000000
--- a/rxvt-unicode-256color/rxvt-unicode.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Name=rxvt-unicode
-Comment=An Unicode capable rxvt clone
-Exec=urxvt
-Icon=rxvt-unicode
-Terminal=false
-Type=Application
-Categories=System;TerminalEmulator;
diff --git a/rxvt-unicode-256color/rxvt-unicode.png b/rxvt-unicode-256color/rxvt-unicode.png
deleted file mode 100644
index 0738a78..0000000
--- a/rxvt-unicode-256color/rxvt-unicode.png
+++ /dev/null
Binary files differ