summaryrefslogtreecommitdiffstats
path: root/spampd/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'spampd/PKGBUILD')
-rw-r--r--spampd/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/spampd/PKGBUILD b/spampd/PKGBUILD
new file mode 100644
index 0000000..f9c7abd
--- /dev/null
+++ b/spampd/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Florian "Bluewind" Pritz <flo@xssn.at>
+pkgname=spampd
+pkgver=2.30
+pkgrel=2
+pkgdesc="Spamassassin Proxy Daemon"
+arch=('any')
+url="http://www.worlddesign.com/index.cfm/rd/mta/spampd.htm"
+license=('GPL')
+depends=('perl' 'perl-net-server' 'spamassassin')
+backup=(etc/conf.d/spampd)
+install=spampd.install
+source=("http://www.worlddesign.com/Content/rd/mta/$pkgname/$pkgname-$pkgver.tar.gz"
+ rc-script rc-config)
+md5sums=('742c6f2cb75db54e59d044a8ee40445f'
+ '769f8a73765a0e7d235c9909aeb7ede9'
+ '637c2d93f76ba90d217e2418af64c9ec')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make
+ install -Dm755 spampd "$pkgdir/usr/bin/spampd"
+ install -Dm755 "$srcdir/rc-script" "$pkgdir/etc/rc.d/spampd"
+ install -Dm644 "$srcdir/rc-config" "$pkgdir/etc/conf.d/spampd"
+ install -Dm644 spampd.8.gz "$pkgdir/usr/share/man/man8/spampd.8.gz"
+ install -m644 changelog.txt "$startdir/ChangeLog"
+}
+
+# vim:set ts=2 sw=2 et: