summaryrefslogtreecommitdiffstats
path: root/spampd
diff options
context:
space:
mode:
Diffstat (limited to 'spampd')
-rw-r--r--spampd/PKGBUILD37
-rw-r--r--spampd/perl-5.18-fixes.patch42
-rw-r--r--spampd/rc-config2
-rwxr-xr-xspampd/rc-script44
-rw-r--r--spampd/spampd.install10
-rw-r--r--spampd/spampd.service10
6 files changed, 0 insertions, 145 deletions
diff --git a/spampd/PKGBUILD b/spampd/PKGBUILD
deleted file mode 100644
index 7fe927a..0000000
--- a/spampd/PKGBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# Maintainer: Florian "Bluewind" Pritz <flo@xssn.at>
-pkgname=spampd
-pkgver=2.30
-pkgrel=9
-pkgdesc="Spamassassin Proxy Daemon"
-arch=('any')
-url="http://www.worlddesign.com/index.cfm/rd/mta/spampd.htm"
-license=('GPL')
-depends=('perl' 'perl-net-server' 'spamassassin')
-install=spampd.install
-source=("http://www.worlddesign.com/Content/rd/mta/$pkgname/$pkgname-$pkgver.tar.gz"
- spampd.service perl-5.18-fixes.patch)
-md5sums=('742c6f2cb75db54e59d044a8ee40445f'
- 'f29bea0766c07a18f6dc0a496a79e0ac'
- '55ea1067be9e70c60b708d355b085a0a')
-
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
-
- patch -p1 -i "$srcdir/perl-5.18-fixes.patch"
-}
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- make
-}
-
-package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- install -Dm755 spampd "$pkgdir/usr/bin/spampd"
- install -Dm644 spampd.8.gz "$pkgdir/usr/share/man/man8/spampd.8.gz"
- install -Dm644 "$srcdir/spampd.service" "$pkgdir/usr/lib/systemd/system/spampd.service"
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/spampd/perl-5.18-fixes.patch b/spampd/perl-5.18-fixes.patch
deleted file mode 100644
index 9b4637b..0000000
--- a/spampd/perl-5.18-fixes.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff --git a/spampd b/spampd
-index 7b1f234..2798d50 100644
---- a/spampd
-+++ b/spampd
-@@ -937,6 +937,10 @@ if ( !$options{logsock} ) {
- };
- }
-
-+# untaint some args to prevent errors in other modules
-+($pidfile) = ($pidfile =~ /^(.+)$/);
-+($relayhost) = ($relayhost =~ /^(.+)$/);
-+($relayport) = ($relayport =~ /^(.+)$/);
-
- my $server = bless {
- server => {host => $host,
-@@ -1147,10 +1151,10 @@ L<http://www.WorldDesign.com/index.cfm/rd/mta/spampd.htm>.
-
- =head1 Requires
-
--=over 5
--
- Perl modules:
-
-+=over 5
-+
- =item B<Mail::SpamAssassin>
-
- =item B<Net::Server::PreForkSimple>
-@@ -1478,11 +1482,11 @@ Prints usage information.
-
- =head2 Deprecated Options
-
--=over 5
--
- The following options are no longer used but still accepted for backwards
- compatibility with prevoius I<spampd> versions:
-
-+=over 5
-+
- =item B<--dead-letters>
-
- =item B<--heloname>
diff --git a/spampd/rc-config b/spampd/rc-config
deleted file mode 100644
index f80d59c..0000000
--- a/spampd/rc-config
+++ /dev/null
@@ -1,2 +0,0 @@
-# for information see manpage or spampd --help
-ARGS="--port=10025 --relayhost=127.0.0.1:10026 --tagall --rh --user spampd --group spampd --pid=/home/spampd/spampd.pid"
diff --git a/spampd/rc-script b/spampd/rc-script
deleted file mode 100755
index 7c4b059..0000000
--- a/spampd/rc-script
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-. /etc/conf.d/spampd
-
-start() {
- stat_busy "Starting Spampd"
- su -l spampd -c "/usr/bin/spampd $ARGS"
- if [ $? -gt 0 ]; then
- stat_fail
- else
- add_daemon spampd
- stat_done
- fi
-}
-
-stop() {
- stat_busy "Stopping Spampd"
- kill $(cat /home/spampd/spampd.pid)
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm_daemon spampd
- stat_done
- fi
-}
-
-case "$1" in
- start)
- start
- ;;
- stop)
- stop
- ;;
- restart)
- # calling 'stop' and 'start' without the $0 fails...
- $0 stop
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
-exit 0
diff --git a/spampd/spampd.install b/spampd/spampd.install
deleted file mode 100644
index d1393ec..0000000
--- a/spampd/spampd.install
+++ /dev/null
@@ -1,10 +0,0 @@
-post_install() {
- useradd -m -d /home/spampd -r spampd
-}
-
-post_remove() {
- userdel spampd
- echo "Remove /home/spampd if you don't want to keep spamassassin's data" >&2
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/spampd/spampd.service b/spampd/spampd.service
deleted file mode 100644
index 084d5cf..0000000
--- a/spampd/spampd.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Spamassassin Proxy Daemon
-After=network.target
-
-[Service]
-ExecStart=/usr/bin/spampd --port=10025 --relayhost=127.0.0.1:10026 --tagall --log-rules-hit --user spampd --group spampd --pid=/home/spampd/spampd.pid --nodetach
-PrivateTmp=true
-
-[Install]
-WantedBy=multi-user.target