summaryrefslogtreecommitdiffstats
path: root/suphp/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'suphp/PKGBUILD')
-rw-r--r--suphp/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/suphp/PKGBUILD b/suphp/PKGBUILD
new file mode 100644
index 0000000..9216d74
--- /dev/null
+++ b/suphp/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: helios <helios@cyb0rg.org>
+pkgname=suphp
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="A tool for executing PHP scripts with the permissions of their owners."
+arch=("i686" "x86_64")
+depends=("apr-util" "apache")
+url="http://www.suphp.org/"
+license=('GPL')
+backup=('etc/suphp/suphp.conf')
+source=(http://www.suphp.org/download/$pkgname-$pkgver.tar.gz suphp.conf)
+md5sums=('c172dd4f15a75f4dcb08ea97d4202bb8' '797fb760d6a8ae833959f6b5cb64a2c1')
+
+build() {
+ cd "$startdir/src/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr --with-apr=/usr/bin/apr-1-config --sysconfdir=/etc/suphp --with-apache-user=http --with-setid-mode=owner --with-min-uid=33 --with-min-gid=33
+ make || return 1
+ make DESTDIR="$startdir/pkg" install
+
+ install -D -m 644 ${startdir}/suphp.conf ${startdir}/pkg/etc/suphp/suphp.conf
+ install -D -m 644 ${startdir}/src/$pkgname-$pkgver/doc/suphp.conf-example ${startdir}/pkg/etc/suphp/suphp.conf.example
+}
+
+# vim:set ts=2 sw=2 et: