summaryrefslogtreecommitdiffstats
path: root/suphp
diff options
context:
space:
mode:
Diffstat (limited to 'suphp')
-rw-r--r--suphp/PKGBUILD25
-rw-r--r--suphp/suphp.conf47
2 files changed, 0 insertions, 72 deletions
diff --git a/suphp/PKGBUILD b/suphp/PKGBUILD
deleted file mode 100644
index 9216d74..0000000
--- a/suphp/PKGBUILD
+++ /dev/null
@@ -1,25 +0,0 @@
-# Contributor: helios <helios@cyb0rg.org>
-pkgname=suphp
-pkgver=0.7.1
-pkgrel=1
-pkgdesc="A tool for executing PHP scripts with the permissions of their owners."
-arch=("i686" "x86_64")
-depends=("apr-util" "apache")
-url="http://www.suphp.org/"
-license=('GPL')
-backup=('etc/suphp/suphp.conf')
-source=(http://www.suphp.org/download/$pkgname-$pkgver.tar.gz suphp.conf)
-md5sums=('c172dd4f15a75f4dcb08ea97d4202bb8' '797fb760d6a8ae833959f6b5cb64a2c1')
-
-build() {
- cd "$startdir/src/$pkgname-$pkgver"
-
- ./configure --prefix=/usr --with-apr=/usr/bin/apr-1-config --sysconfdir=/etc/suphp --with-apache-user=http --with-setid-mode=owner --with-min-uid=33 --with-min-gid=33
- make || return 1
- make DESTDIR="$startdir/pkg" install
-
- install -D -m 644 ${startdir}/suphp.conf ${startdir}/pkg/etc/suphp/suphp.conf
- install -D -m 644 ${startdir}/src/$pkgname-$pkgver/doc/suphp.conf-example ${startdir}/pkg/etc/suphp/suphp.conf.example
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/suphp/suphp.conf b/suphp/suphp.conf
deleted file mode 100644
index a4c6cdf..0000000
--- a/suphp/suphp.conf
+++ /dev/null
@@ -1,47 +0,0 @@
-[global]
-;Path to logfile
-logfile=/var/log/suphp.log
-
-;Loglevel
-loglevel=info
-
-;User Apache is running as
-webserver_user=http
-
-;Path all scripts have to be in
-docroot=/var/www:${HOME}/public_html:/srv/http
-
-;Path to chroot() to before executing script
-;chroot=/mychroot
-
-; Security options
-allow_file_group_writeable=false
-allow_file_others_writeable=false
-allow_directory_group_writeable=false
-allow_directory_others_writeable=false
-
-;Check wheter script is within DOCUMENT_ROOT
-check_vhost_docroot=false
-
-;Send minor error messages to browser
-errors_to_browser=true
-
-;PATH environment variable
-env_path=/bin:/usr/bin
-
-;Umask to set, specify in octal notation
-umask=0077
-
-; Minimum UID
-min_uid=33
-
-; Minimum GID
-min_gid=33
-
-
-[handlers]
-;Handler for php-scripts
-x-httpd-php="php:/usr/bin/php-cgi"
-
-;Handler for CGI-scripts
-x-suphp-cgi="execute:!self"