summaryrefslogtreecommitdiffstats
path: root/task/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'task/PKGBUILD')
-rw-r--r--task/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/task/PKGBUILD b/task/PKGBUILD
new file mode 100644
index 0000000..a8aedf8
--- /dev/null
+++ b/task/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: TDY <tdy@gmx.com>
+# Contributor: Ray Kohler <ataraxia@gmail.com>
+# Contributor: muflax <muflax@gmail.com>
+
+pkgname=task
+pkgver=1.9.2
+pkgrel=1
+pkgdesc="A command-line todo list manager"
+arch=('i686' 'x86_64')
+url="http://taskwarrior.org/projects/show/taskwarrior/"
+license=('GPL')
+depends=('gcc-libs' 'ncurses')
+source=(http://www.taskwarrior.org/download/$pkgname-$pkgver.tar.gz)
+md5sums=('be98cc74fe03b8336250e0b7ed3cd8c7')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make CXXFLAGS="$CXXFLAGS" || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}