summaryrefslogtreecommitdiffstats
path: root/tcc-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'tcc-git/PKGBUILD')
-rw-r--r--tcc-git/PKGBUILD35
1 files changed, 0 insertions, 35 deletions
diff --git a/tcc-git/PKGBUILD b/tcc-git/PKGBUILD
deleted file mode 100644
index 7597ce4..0000000
--- a/tcc-git/PKGBUILD
+++ /dev/null
@@ -1,35 +0,0 @@
-pkgname=tcc-git
-pkgver=20100328
-pkgrel=1
-pkgdesc="Tiny C Compiler - small, simple, and fast single-pass C compiler"
-arch=('i686' 'x86_64')
-url="http://bellard.org/tcc/"
-license=('LGPLv2')
-makedepends=('git' 'texi2html')
-provides=('tcc')
-conflicts=('tcc')
-
-_gitroot="git://repo.or.cz/tinycc.git"
-_gitname="tinycc"
-
-build()
-{
- cd $srcdir
-
- msg "Connecting to GIT server..."
- if [ -d "$srcdir/$_gitname" ] ; then
- git --git-dir=$_gitname/.git pull origin
- else
- git clone $_gitroot
- fi
- msg "GIT checkout done or server timeout"
-
- msg "Starting make..."
- rm -rf $_gitname-build
- cp -r $_gitname $_gitname-build
- cd $_gitname-build
- sed -i 's/CONFIG_TCCDIR \\\"\$tccdir\\\"/CONFIG_TCCDIR \\\"\/usr\/lib\/tcc\\\"/' configure
- ./configure --prefix="$pkgdir/usr"
- make || return 1
- make install || return 1
-}