summaryrefslogtreecommitdiffstats
path: root/thunar-notrash/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'thunar-notrash/PKGBUILD')
-rw-r--r--thunar-notrash/PKGBUILD51
1 files changed, 31 insertions, 20 deletions
diff --git a/thunar-notrash/PKGBUILD b/thunar-notrash/PKGBUILD
index a024ad4..2992f89 100644
--- a/thunar-notrash/PKGBUILD
+++ b/thunar-notrash/PKGBUILD
@@ -3,42 +3,53 @@
# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
pkgname=thunar-notrash
-pkgver=1.0.2
+pkgver=1.1.6
pkgrel=1
pkgdesc="new modern file manager for Xfce with patch to disable trash"
arch=(i686 x86_64)
-license=('GPL2' 'LGPL2')
+license=('GPL2' 'LGPL2.1')
url="http://thunar.xfce.org"
groups=('xfce4')
conflicts=(thunar)
provides=("thunar=$pkgver")
-depends=('desktop-file-utils' 'libexif>=0.6.19' 'hicolor-icon-theme' 'fam' \
- 'gtk2' 'exo>=0.3.107' 'libxfce4util>=4.6.2' 'hal>=0.5.14' 'libpng' 'libjpeg>=8.0.1' 'startup-notification')
-makedepends=('intltool' 'pkgconfig' 'xfce4-panel>=4.6.4')
-optdepends=('gamin: a fam replacement to make thunar monitor changes to files on the fly')
+depends=('desktop-file-utils' 'libexif' 'hicolor-icon-theme' 'libnotify' 'udev'
+ 'gtk2' 'exo>=0.5.4' 'libxfce4util>=4.7.3' 'libxfce4ui' 'libpng') # 'fam' - obsolete?
+makedepends=('intltool' 'gtk-doc' 'xfce4-panel>=4.7.4')
+optdepends=( # 'gamin: a fam replacement to make thunar monitor changes to files on the fly'
+ 'xfce4-panel: for trash applet'
+ 'tumbler: for thumbnail previews')
options=('!libtool')
-install=${pkgname}.install
-source=(http://archive.xfce.org/src/xfce/thunar/1.0/Thunar-${pkgver}.tar.bz2
- Ability_to_disable_trash_on_Thunar.patch)
+install=thunar-notrash.install
+source=(http://archive.xfce.org/src/xfce/thunar/1.1/Thunar-${pkgver}.tar.bz2
+ Ability_to_disable_trash_on_Thunar_$pkgver.patch)
+md5sums=('a96fdbc0b3d422f864d50374b5d6be41'
+ 'a2c1ccb1148667395bb3e1f27ba9d467')
build() {
cd ${srcdir}/Thunar-${pkgver}
- patch -p2 < $srcdir/Ability_to_disable_trash_on_Thunar.patch
+ patch -p2 < $srcdir/Ability_to_disable_trash_on_Thunar_$pkgver.patch
- ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
- --localstatedir=/var --disable-static \
- --disable-gnome-thumbnailers --enable-exif --enable-pcre \
- --disable-wallpaper-plugin
- make || return 1
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-gio-unix \
+ --enable-dbus \
+ --enable-startup-notification \
+ --enable-gudev \
+ --enable-notifications \
+ --enable-exif \
+ --enable-pcre \
+ --enable-gtk-doc \
+ --disable-debug
+
+ make
}
package() {
cd ${srcdir}/Thunar-${pkgver}
- make DESTDIR=${pkgdir} install || return 1
+ make DESTDIR=${pkgdir} install
sed -i 's:x-directory/gnome-default-handler;::' \
${pkgdir}/usr/share/applications/Thunar-folder-handler.desktop
}
-md5sums=('c91073202d373a1f9951a1240083c36d'
- '55816882bbeac5bb1153f0b195a220d7')
-sha1sums=('f7ae00c32402e4bc502aba15477b78e2c558c7c3'
- 'c4b110b2a83b6d7b88e04bb550d20c598ffe6f82')