summaryrefslogtreecommitdiffstats
path: root/thunar-notrash/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'thunar-notrash/PKGBUILD')
-rw-r--r--thunar-notrash/PKGBUILD31
1 files changed, 15 insertions, 16 deletions
diff --git a/thunar-notrash/PKGBUILD b/thunar-notrash/PKGBUILD
index 241479f..0bae7d7 100644
--- a/thunar-notrash/PKGBUILD
+++ b/thunar-notrash/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
pkgname=thunar-notrash
-pkgver=1.0.1
-pkgrel=2
+pkgver=1.0.2
+pkgrel=1
pkgdesc="new modern file manager for Xfce with patch to disable trash"
arch=(i686 x86_64)
license=('GPL2' 'LGPL2')
@@ -12,34 +12,33 @@ url="http://thunar.xfce.org"
groups=('xfce4')
conflicts=(thunar)
provides=("thunar=$pkgver")
-depends=('desktop-file-utils' 'libexif>=0.6.17' 'xfce4-panel>=4.6.1' 'hicolor-icon-theme' 'fam')
-makedepends=('intltool' 'pkgconfig')
+depends=('desktop-file-utils' 'libexif>=0.6.19' 'hicolor-icon-theme' 'fam' \
+ 'gtk2' 'exo>=0.3.107' 'libxfce4util>=4.6.2' 'hal>=0.5.14' 'libpng' 'libjpeg>=8.0.1' 'startup-notification')
+makedepends=('intltool' 'pkgconfig' 'xfce4-panel>=4.6.4')
optdepends=('gamin: a fam replacement to make thunar monitor changes to files on the fly')
options=('!libtool')
install=${pkgname}.install
-source=(http://www.xfce.org/archive/xfce-4.6.1/src/Thunar-${pkgver}.tar.bz2 Ability_to_disable_trash_on_Thunar.patch
- thunar-vfs-fix-umask.patch libpng-1.4.patch)
+source=(http://archive.xfce.org/src/xfce/thunar/1.0/Thunar-${pkgver}.tar.bz2
+ Ability_to_disable_trash_on_Thunar.patch)
build() {
cd ${srcdir}/Thunar-${pkgver}
patch -p2 < $srcdir/Ability_to_disable_trash_on_Thunar.patch
- patch -p1 < ../libpng-1.4.patch
- patch -Np0 -i ${srcdir}/thunar-vfs-fix-umask.patch
./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
--localstatedir=/var --disable-static \
--disable-gnome-thumbnailers --enable-exif --enable-pcre \
--disable-wallpaper-plugin
make || return 1
+}
+
+package() {
+ cd ${srcdir}/Thunar-${pkgver}
make DESTDIR=${pkgdir} install || return 1
sed -i 's:x-directory/gnome-default-handler;::' \
${pkgdir}/usr/share/applications/Thunar-folder-handler.desktop
}
-md5sums=('218373aa45d74b6ba8c69c4d5af3bb19'
- '55816882bbeac5bb1153f0b195a220d7'
- '7247041fd2c411e4a129d3f90350893c'
- 'ee998c20ba13d0cb18741da8b7d67328')
-sha1sums=('2fcd3a7b0e27b01f059dffc8ffdac94e2b2aa064'
- 'c4b110b2a83b6d7b88e04bb550d20c598ffe6f82'
- '47526f997627264813843cf466c5ee9335047458'
- '99f520655582acb5bffbee72bf0bc37aef37bc69')
+md5sums=('c91073202d373a1f9951a1240083c36d'
+ '55816882bbeac5bb1153f0b195a220d7')
+sha1sums=('f7ae00c32402e4bc502aba15477b78e2c558c7c3'
+ 'c4b110b2a83b6d7b88e04bb550d20c598ffe6f82')