summaryrefslogtreecommitdiffstats
path: root/thunar-notrash/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'thunar-notrash/PKGBUILD')
-rw-r--r--thunar-notrash/PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/thunar-notrash/PKGBUILD b/thunar-notrash/PKGBUILD
index ac83f3d..cc687f3 100644
--- a/thunar-notrash/PKGBUILD
+++ b/thunar-notrash/PKGBUILD
@@ -18,11 +18,14 @@ optdepends=('gamin: a fam replacement to make thunar monitor changes to files
options=('!libtool')
install=${pkgname}.install
source=(http://www.xfce.org/archive/xfce-4.6.1/src/Thunar-${pkgver}.tar.bz2 Ability_to_disable_trash_on_Thunar.patch
-)
+ thunar-vfs-fix-umask.patch libpng-1.4.patch)
build() {
cd ${srcdir}/Thunar-${pkgver}
patch -p2 < $srcdir/Ability_to_disable_trash_on_Thunar.patch
+ patch -p1 < ../libpng-1.4.patch
+ patch -Np0 -i ${srcdir}/thunar-vfs-fix-umask.patch
+
./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
--localstatedir=/var --disable-static \
--disable-gnome-thumbnailers --enable-exif --enable-pcre \
@@ -33,6 +36,10 @@ build() {
${pkgdir}/usr/share/applications/Thunar-folder-handler.desktop
}
md5sums=('218373aa45d74b6ba8c69c4d5af3bb19'
- '55816882bbeac5bb1153f0b195a220d7')
-sha256sums=('7a2b6b493463756bbc9c54144fab2f2163bc84f0896b4c06fd225d11025a210d'
- 'e235ac3f5559d685051bb747b348238a925de32653e8e8c9b8b89c1e0bb56a67')
+ '55816882bbeac5bb1153f0b195a220d7'
+ '7247041fd2c411e4a129d3f90350893c'
+ 'ee998c20ba13d0cb18741da8b7d67328')
+sha1sums=('2fcd3a7b0e27b01f059dffc8ffdac94e2b2aa064'
+ 'c4b110b2a83b6d7b88e04bb550d20c598ffe6f82'
+ '47526f997627264813843cf466c5ee9335047458'
+ '99f520655582acb5bffbee72bf0bc37aef37bc69')