summaryrefslogtreecommitdiffstats
path: root/thunar-notrash/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'thunar-notrash/PKGBUILD')
-rw-r--r--thunar-notrash/PKGBUILD38
1 files changed, 24 insertions, 14 deletions
diff --git a/thunar-notrash/PKGBUILD b/thunar-notrash/PKGBUILD
index 2992f89..69e516f 100644
--- a/thunar-notrash/PKGBUILD
+++ b/thunar-notrash/PKGBUILD
@@ -1,29 +1,35 @@
# Maintainer: Florian Pritz <flo@xssn.at>
-# Contributor:: tobias <tobias funnychar archlinux.org>
-# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
+
pkgname=thunar-notrash
-pkgver=1.1.6
+pkgver=1.2.0
pkgrel=1
-pkgdesc="new modern file manager for Xfce with patch to disable trash"
-arch=(i686 x86_64)
+pkgdesc="modern file manager for Xfce with patch to disable trash"
+arch=('i686' 'x86_64')
license=('GPL2' 'LGPL2.1')
url="http://thunar.xfce.org"
groups=('xfce4')
conflicts=(thunar)
provides=("thunar=$pkgver")
depends=('desktop-file-utils' 'libexif' 'hicolor-icon-theme' 'libnotify' 'udev'
- 'gtk2' 'exo>=0.5.4' 'libxfce4util>=4.7.3' 'libxfce4ui' 'libpng') # 'fam' - obsolete?
-makedepends=('intltool' 'gtk-doc' 'xfce4-panel>=4.7.4')
-optdepends=( # 'gamin: a fam replacement to make thunar monitor changes to files on the fly'
+ 'gtk2' 'exo>=0.6.0' 'libxfce4util>=4.8.1' 'libxfce4ui' 'libpng')
+makedepends=('intltool' 'gtk-doc' 'xfce4-panel>=4.8.0')
+optdepends=('gvfs: for trash support, mounting with udisk and remote filesystems'
'xfce4-panel: for trash applet'
- 'tumbler: for thumbnail previews')
+ 'tumbler: for thumbnail previews'
+ 'thunar-volman: manages removable devices'
+ 'thunar-archive-plugin: create and deflate archives'
+ 'thunar-media-tags-plugin: view/edit id3/ogg tags')
options=('!libtool')
install=thunar-notrash.install
-source=(http://archive.xfce.org/src/xfce/thunar/1.1/Thunar-${pkgver}.tar.bz2
- Ability_to_disable_trash_on_Thunar_$pkgver.patch)
-md5sums=('a96fdbc0b3d422f864d50374b5d6be41'
- 'a2c1ccb1148667395bb3e1f27ba9d467')
+backup=('etc/polkit-1/localauthority/50-local.d/org.freedesktop.udisks.pkla')
+source=(http://archive.xfce.org/src/xfce/thunar/1.2/Thunar-${pkgver}.tar.bz2
+ Ability_to_disable_trash_on_Thunar_$pkgver.patch
+ org.freedesktop.udisks.pkla)
+
+md5sums=('3f270cfbb83a057e6db46cdea549af8b'
+ 'a2c1ccb1148667395bb3e1f27ba9d467'
+ 'a7ddb5eec02d9a8e91a2997862e73cd8')
build() {
cd ${srcdir}/Thunar-${pkgver}
@@ -43,7 +49,6 @@ build() {
--enable-pcre \
--enable-gtk-doc \
--disable-debug
-
make
}
@@ -52,4 +57,9 @@ package() {
make DESTDIR=${pkgdir} install
sed -i 's:x-directory/gnome-default-handler;::' \
${pkgdir}/usr/share/applications/Thunar-folder-handler.desktop
+
+ # install udisks permission file
+ install -dm700 ${pkgdir}/etc/polkit-1/localauthority
+ install -dm755 ${pkgdir}/etc/polkit-1/localauthority/50-local.d
+ install -m644 ${srcdir}/org.freedesktop.udisks.pkla ${pkgdir}/etc/polkit-1/localauthority/50-local.d/
}