summaryrefslogtreecommitdiffstats
path: root/thunar-notrash/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'thunar-notrash/PKGBUILD')
-rw-r--r--thunar-notrash/PKGBUILD71
1 files changed, 46 insertions, 25 deletions
diff --git a/thunar-notrash/PKGBUILD b/thunar-notrash/PKGBUILD
index 0bae7d7..0db9c90 100644
--- a/thunar-notrash/PKGBUILD
+++ b/thunar-notrash/PKGBUILD
@@ -1,44 +1,65 @@
-# $Id$
-# Maintainer: tobias <tobias funnychar archlinux.org>
-# Contributor: Andrew Simmons <andrew.simmons@gmail.com>
+# Maintainer: Florian Pritz <flo@xssn.at>
+
pkgname=thunar-notrash
-pkgver=1.0.2
+pkgver=1.3.0
pkgrel=1
-pkgdesc="new modern file manager for Xfce with patch to disable trash"
-arch=(i686 x86_64)
-license=('GPL2' 'LGPL2')
+pkgdesc="modern file manager for Xfce with patch to disable trash"
+arch=('i686' 'x86_64')
+license=('GPL2' 'LGPL2.1')
url="http://thunar.xfce.org"
groups=('xfce4')
conflicts=(thunar)
provides=("thunar=$pkgver")
-depends=('desktop-file-utils' 'libexif>=0.6.19' 'hicolor-icon-theme' 'fam' \
- 'gtk2' 'exo>=0.3.107' 'libxfce4util>=4.6.2' 'hal>=0.5.14' 'libpng' 'libjpeg>=8.0.1' 'startup-notification')
-makedepends=('intltool' 'pkgconfig' 'xfce4-panel>=4.6.4')
-optdepends=('gamin: a fam replacement to make thunar monitor changes to files on the fly')
+depends=('desktop-file-utils' 'libexif' 'hicolor-icon-theme' 'libnotify' 'udev'
+ 'gtk2' 'exo>=0.6.0' 'libxfce4util>=4.8.1' 'libxfce4ui' 'libpng')
+makedepends=('intltool' 'gtk-doc' 'xfce4-panel>=4.8.0')
+optdepends=('gvfs: for trash support, mounting with udisk and remote filesystems'
+ 'xfce4-panel: for trash applet'
+ 'tumbler: for thumbnail previews'
+ 'thunar-volman: manages removable devices'
+ 'thunar-archive-plugin: create and deflate archives'
+ 'thunar-media-tags-plugin: view/edit id3/ogg tags')
options=('!libtool')
-install=${pkgname}.install
-source=(http://archive.xfce.org/src/xfce/thunar/1.0/Thunar-${pkgver}.tar.bz2
- Ability_to_disable_trash_on_Thunar.patch)
+install=thunar-notrash.install
+backup=('etc/polkit-1/localauthority/50-local.d/org.freedesktop.udisks.pkla')
+source=(http://archive.xfce.org/src/xfce/thunar/1.3/Thunar-${pkgver}.tar.bz2
+ Ability_to_disable_trash_on_Thunar_$pkgver.patch
+ org.freedesktop.udisks.pkla)
+
+md5sums=('ab6f728384c0d925b40afae2f41268f3'
+ 'a2c1ccb1148667395bb3e1f27ba9d467'
+ 'a7ddb5eec02d9a8e91a2997862e73cd8')
build() {
cd ${srcdir}/Thunar-${pkgver}
- patch -p2 < $srcdir/Ability_to_disable_trash_on_Thunar.patch
+ patch -p2 < $srcdir/Ability_to_disable_trash_on_Thunar_$pkgver.patch
- ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
- --localstatedir=/var --disable-static \
- --disable-gnome-thumbnailers --enable-exif --enable-pcre \
- --disable-wallpaper-plugin
- make || return 1
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-gio-unix \
+ --enable-dbus \
+ --enable-startup-notification \
+ --enable-gudev \
+ --enable-notifications \
+ --enable-exif \
+ --enable-pcre \
+ --enable-gtk-doc \
+ --disable-debug
+ make
}
package() {
cd ${srcdir}/Thunar-${pkgver}
- make DESTDIR=${pkgdir} install || return 1
+ make DESTDIR=${pkgdir} install
sed -i 's:x-directory/gnome-default-handler;::' \
${pkgdir}/usr/share/applications/Thunar-folder-handler.desktop
+
+ # install udisks permission file
+ install -dm700 ${pkgdir}/etc/polkit-1/localauthority
+ install -dm755 ${pkgdir}/etc/polkit-1/localauthority/50-local.d
+ install -m644 ${srcdir}/org.freedesktop.udisks.pkla ${pkgdir}/etc/polkit-1/localauthority/50-local.d/
}
-md5sums=('c91073202d373a1f9951a1240083c36d'
- '55816882bbeac5bb1153f0b195a220d7')
-sha1sums=('f7ae00c32402e4bc502aba15477b78e2c558c7c3'
- 'c4b110b2a83b6d7b88e04bb550d20c598ffe6f82')