summaryrefslogtreecommitdiffstats
path: root/tipp10/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'tipp10/PKGBUILD')
-rw-r--r--tipp10/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/tipp10/PKGBUILD b/tipp10/PKGBUILD
new file mode 100644
index 0000000..647f5f5
--- /dev/null
+++ b/tipp10/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: toliman <altergan@hs-albsig.de>
+pkgname=tipp10
+pkgver=2.0.3
+pkgrel=1
+pkgdesc="intelligent typing tutor (german only)"
+arch=('i686' 'x86_64')
+url="http://www.tipp10.de/"
+license=('GPL2')
+depends=('qt>=4.2.2')
+makedepends=('unzip' 'make')
+source=(tipp10.desktop tipp10.png \
+ "http://flo.server-speed.net/stuff/mirror/tipp10_source_v2-0-3.zip")
+
+build() {
+ sed -i 's/tipp10v2.template/..\/share\/tipp10\/tipp10v2.template/' $srcdir/tipp10/def/defines.h
+
+ cd $srcdir/tipp10
+ qmake
+ make || return 1
+ install -D tipp10 $pkgdir/usr/bin/tipp10
+ install -D tipp10v2.template $pkgdir/usr/share/tipp10/tipp10v2.template
+ install -D $srcdir/tipp10.png $pkgdir/usr/share/pixmaps/tipp10.png
+ install -D $srcdir/tipp10.desktop $pkgdir/usr/share/applications/tipp10.desktop
+}
+
+md5sums=('e0d6c26220396551386f91ce893e040c'
+ 'ff788e726d357370df1e7c8b19d38fd4'
+ 'bac29896ec992496f7e0aab992993004')
+sha256sums=('ed18e5cb625463595ca4d84c9e4576d42af407c31a29a76e2bc7a8538288d35d'
+ '83c2574c3ba23b3344669bf15cbd618dfe8ddc3863bdfce1d70ba22200bd8ff0'
+ 'bf44edc1524b8dac07c0d501368411cc13e5c1a2a6ffb0d1b4d576ba1ad80fd5')