summaryrefslogtreecommitdiffstats
path: root/tipp10
diff options
context:
space:
mode:
Diffstat (limited to 'tipp10')
-rw-r--r--tipp10/PKGBUILD38
-rw-r--r--tipp10/defines.h.patch16
-rw-r--r--tipp10/gcc-4.5.patch99
-rw-r--r--tipp10/tipp10.desktop11
-rw-r--r--tipp10/tipp10.pngbin1336 -> 0 bytes
5 files changed, 0 insertions, 164 deletions
diff --git a/tipp10/PKGBUILD b/tipp10/PKGBUILD
deleted file mode 100644
index 21ba863..0000000
--- a/tipp10/PKGBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# Maintainer: Florian Pritz <f-p@gmx.at>
-# Contributor: toliman <altergan@hs-albsig.de>
-
-pkgname=tipp10
-pkgver=2.0.3
-pkgrel=3
-pkgdesc="intelligent typing tutor (german only)"
-arch=('i686' 'x86_64')
-url="http://www.tipp10.de/"
-license=('GPL2')
-depends=('qt>=4.2.2')
-makedepends=('unzip' 'make')
-source=(tipp10.desktop tipp10.png defines.h.patch gcc-4.5.patch \
- "http://www.tipp10.de/download_hidden/tipp10_source_v2-0-3.zip")
-
-build() {
- sed -i 's/tipp10v2.template/..\/share\/tipp10\/tipp10v2.template/' $srcdir/tipp10/def/defines.h
-
- cd $srcdir/tipp10
- patch -p0 < "$srcdir/defines.h.patch" || return 1
- patch -p0 < "$srcdir/gcc-4.5.patch" || return 1
- qmake
- make || return 1
- install -D tipp10 $pkgdir/usr/bin/tipp10
- install -D tipp10v2.template $pkgdir/usr/share/tipp10/tipp10v2.template
- install -D $srcdir/tipp10.png $pkgdir/usr/share/pixmaps/tipp10.png
- install -D $srcdir/tipp10.desktop $pkgdir/usr/share/applications/tipp10.desktop
-}
-md5sums=('e0d6c26220396551386f91ce893e040c'
- 'ff788e726d357370df1e7c8b19d38fd4'
- 'ce67b64cb3a1d25119acd1a43804304d'
- 'a9d388ddb17ae93f13acb915bc8eba57'
- 'bac29896ec992496f7e0aab992993004')
-sha1sums=('c0f9f6dab87ed2cc0557bd0bc29a102f8f4483b7'
- '42cc902010030dcea92dd64053523e24028b2dae'
- '340aa263721b9fc1df74a1cc828c990061c7d625'
- '3eb601ab7c1d68d8c64e949e7e4f8a83b06a518e'
- 'faf8c7799c934eaca83a0e077cf9ba458334680b')
diff --git a/tipp10/defines.h.patch b/tipp10/defines.h.patch
deleted file mode 100644
index 4ff291c..0000000
--- a/tipp10/defines.h.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- def/defines.h.orig 2009-03-09 13:02:26.000000000 +0100
-+++ def/defines.h 2009-03-09 13:02:41.000000000 +0100
-@@ -27,10 +27,10 @@
- #define DEFINES_H
-
- // OS constants
--#define APP_WIN true
-+#define APP_WIN false
- #define APP_MAC false
--#define APP_X11 false
--#define APP_PORTABLE true //at least one of the 3 OS must be true too!
-+#define APP_X11 true
-+#define APP_PORTABLE false //at least one of the 3 OS must be true too!
-
- // Common program constants
- #define APP_ORGANIZATION "Tom Thielicke IT Solutions"
diff --git a/tipp10/gcc-4.5.patch b/tipp10/gcc-4.5.patch
deleted file mode 100644
index dfff820..0000000
--- a/tipp10/gcc-4.5.patch
+++ /dev/null
@@ -1,99 +0,0 @@
---- sql/chartablesql.cpp 2010-05-08 14:53:48.000000000 +0200
-+++ sql/chartablesql.cpp 2010-05-08 14:53:59.000000000 +0200
-@@ -50,7 +50,7 @@
- // Read the unicode value
- unicode = value.toInt();
- // Convert unicode to a char
-- unicodeToChar = QString::QString(QChar(unicode)); //"\'" + QString::QString(QChar(unicode)) + "\'";
-+ unicodeToChar = QString(QChar(unicode)); //"\'" + QString::QString(QChar(unicode)) + "\'";
- return unicodeToChar;
- } else {
- // Last column (error weight)
---- sql/startsql.cpp 2010-05-08 14:54:24.000000000 +0200
-+++ sql/startsql.cpp 2010-05-08 14:54:49.000000000 +0200
-@@ -338,7 +338,7 @@
- for (i = 0; i < content.size(); i++) {
- //simplifiedContent = QString::QString(
- // content.at(i)).replace(QChar(0x27), "''", Qt::CaseSensitive).simplified();
-- simplifiedContent = trim(QString::QString(
-+ simplifiedContent = trim(QString(
- content.at(i)).replace(QChar(0x27), "''", Qt::CaseSensitive));
-
- if (!query.exec("INSERT INTO own_content VALUES(NULL,'" +
---- widget/lessondialog.cpp 2010-05-08 14:52:48.000000000 +0200
-+++ widget/lessondialog.cpp 2010-05-08 14:53:11.000000000 +0200
-@@ -89,7 +89,7 @@
- *lessonData = lineLessonContent->toPlainText().split("\n", QString::SkipEmptyParts);
- // Delete empty lines
- for (int i = 0; i < lessonData->size(); i++) {
-- if (QString::QString(lessonData->at(i).toLocal8Bit().constData()).simplified() == "") {
-+ if (QString(lessonData->at(i).toLocal8Bit().constData()).simplified() == "") {
- lessonData->removeAt(i);
- }
- }
-@@ -268,7 +268,7 @@
- contentList = lineLessonContent->toPlainText().split("\n", QString::SkipEmptyParts);
- // Delete empty lines
- for (i = 0; i < contentList.size(); i++) {
-- if (QString::QString(contentList.at(i).toLocal8Bit().constData()).simplified() == "") {
-+ if (QString(contentList.at(i).toLocal8Bit().constData()).simplified() == "") {
- contentList.removeAt(i);
- }
- }
---- widget/settingspages.cpp 2010-05-08 14:45:41.000000000 +0200
-+++ widget/settingspages.cpp 2010-05-08 14:45:57.000000000 +0200
-@@ -617,7 +617,7 @@
- QSettings settings;
- #endif
- settings.beginGroup("database");
-- settings.setValue("pathpro", lineDatabasePath->text() + "/" + QString::QString(APP_USER_DB));
-+ settings.setValue("pathpro", lineDatabasePath->text() + "/" + QString(APP_USER_DB));
- settings.endGroup();
- }
-
---- widget/tickerboard.cpp 2010-05-08 14:28:38.000000000 +0200
-+++ widget/tickerboard.cpp 2010-05-08 14:44:11.000000000 +0200
-@@ -96,7 +96,7 @@
-
- if (tickerSpeed == 50) {
- scrollOffset = 290;
-- scroll(-290, 0, QRect::QRect(10, 15, 590, 35)); //contentsRect());
-+ scroll(-290, 0, QRect(10, 15, 590, 35)); //contentsRect());
- }
-
- startFlag = true;
-@@ -150,7 +150,7 @@
- scrollOffset = 0;
- } else {
- scrollOffset = 290;
-- scroll(-290, 0, QRect::QRect(10, 15, 590, 35)); //contentsRect());
-+ scroll(-290, 0, QRect(10, 15, 590, 35)); //contentsRect());
- }
- splitLesson();
- }
-@@ -239,7 +239,7 @@
-
- // Move ticker 1 pixel to left
- scrollOffset++;
-- scroll(-1, 0, QRect::QRect(10, 15, 590, 35)); //contentsRect());
-+ scroll(-1, 0, QRect(10, 15, 590, 35)); //contentsRect());
-
- if ((lessonOffset - scrollOffset) <= 30) {
- setSpeed(tickerSpeed);
-@@ -262,14 +262,14 @@
- // 160 pixels overage (because the user must see at least the next word)
- if ((lessonOffset - scrollOffset) > 200) {
- scrollOffset += (lessonOffset - scrollOffset) - 200;
-- scroll(-((lessonOffset - scrollOffset) - 200), 0, QRect::QRect(10, 15, 590, 35)); //contentsRect());
-+ scroll(-((lessonOffset - scrollOffset) - 200), 0, QRect(10, 15, 590, 35)); //contentsRect());
- }
- } else {
- // If the user types faster than the ticker, move ticker faster after
- // 160 pixels overage (because the user must see at least the next word)
- if ((lessonOffset - scrollOffset) > 280) {
- scrollOffset += 570;
-- scroll(-570, 0, QRect::QRect(10, 15, 590, 35)); //contentsRect());
-+ scroll(-570, 0, QRect(10, 15, 590, 35)); //contentsRect());
- }
-
- }
diff --git a/tipp10/tipp10.desktop b/tipp10/tipp10.desktop
deleted file mode 100644
index 702cd98..0000000
--- a/tipp10/tipp10.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Name=TIPP10
-Comment=Intelligent typing tutor
-Comment[de]=Intelligenter 10-Finger-Schreibtrainer
-Type=Application
-Icon=tipp10.png
-Exec=tipp10
-Terminal=false
-Categories=Application;Education;
-
diff --git a/tipp10/tipp10.png b/tipp10/tipp10.png
deleted file mode 100644
index ef06c94..0000000
--- a/tipp10/tipp10.png
+++ /dev/null
Binary files differ