summaryrefslogtreecommitdiffstats
path: root/vim/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'vim/PKGBUILD')
-rw-r--r--vim/PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/vim/PKGBUILD b/vim/PKGBUILD
index c3faac6..d879d73 100644
--- a/vim/PKGBUILD
+++ b/vim/PKGBUILD
@@ -3,16 +3,16 @@
pkgname=vim
_srcver=7.2
-_patchlevel=234
+_patchlevel=267
pkgver=${_srcver}.${_patchlevel}
pkgrel=1
pkgdesc='Vi Improved, a highly configurable, improved version of the vi text editor'
arch=(i686 x86_64)
license=('custom:vim')
url="http://www.vim.org"
-depends=('gpm' 'coreutils')
+depends=('gpm' 'coreutils' 'python')
makedepends=('wget' 'sed' 'grep' 'gettext' 'perl')
-optdepends=('perl: the runtime provides a view useful perl scripts')
+optdepends=('perl: the runtime provides a few useful perl scripts')
backup=(etc/vimrc)
install=${pkgname}.install
# we need the extra-stuff to get all patches applied smoothly
@@ -36,7 +36,7 @@ build()
--with-compiledby=ArchLinux --with-features=big \
--enable-gpm --enable-acl --with-x=no --disable-gui \
--enable-multibyte --enable-cscope \
- --enable-perlinterp
+ --enable-perlinterp --enable-pythoninterp
#--with-global-runtime=/usr/share/vim --with-vim-name=vim \
make || return 1
make VIMRCLOC=/etc DESTDIR=${pkgdir} install
@@ -67,3 +67,10 @@ build()
cd ${pkgdir}/usr/share/licenses/vim
ln -s ../../vim/${_versiondir}/doc/uganda.txt license.txt
}
+md5sums=('f0901284b338e448bfd79ccca0041254'
+ '35e04482f07c57221c9a751aaa3b8dac'
+ 'd8884786979e0e520c112faf2e176f05'
+ '6d7e8d7868e8bfaa9a5880cd9c439320'
+ '45c1c3c6aff7de0d8fc2a9d8cd5cec7d'
+ '98a6065e21cba417870a66b78e9f0210'
+ '10353a61aadc3f276692d0e17db1478e')