summaryrefslogtreecommitdiffstats
path: root/virtualbox_bin
diff options
context:
space:
mode:
Diffstat (limited to 'virtualbox_bin')
-rw-r--r--virtualbox_bin/.gitignore1
-rw-r--r--virtualbox_bin/10-vboxdrv.rules3
-rw-r--r--virtualbox_bin/PKGBUILD104
-rw-r--r--virtualbox_bin/vbox.install102
-rw-r--r--virtualbox_bin/vbox_build_module5
-rw-r--r--virtualbox_bin/vboxdrv54
-rw-r--r--virtualbox_bin/virtualbox.install128
7 files changed, 0 insertions, 397 deletions
diff --git a/virtualbox_bin/.gitignore b/virtualbox_bin/.gitignore
deleted file mode 100644
index 9857323..0000000
--- a/virtualbox_bin/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-*.run
diff --git a/virtualbox_bin/10-vboxdrv.rules b/virtualbox_bin/10-vboxdrv.rules
deleted file mode 100644
index 59babea..0000000
--- a/virtualbox_bin/10-vboxdrv.rules
+++ /dev/null
@@ -1,3 +0,0 @@
-KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="vboxusers", MODE="0660"
-SUBSYSTEM=="usb_device", GROUP="vboxusers", MODE="0664"
-SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", GROUP="vboxusers", MODE="0664"
diff --git a/virtualbox_bin/PKGBUILD b/virtualbox_bin/PKGBUILD
deleted file mode 100644
index 6e82e75..0000000
--- a/virtualbox_bin/PKGBUILD
+++ /dev/null
@@ -1,104 +0,0 @@
-# Maintainer: Lukas Fleischer <archlinux at cryptocrack dot de>
-# Contributor: thotypous <matiasΘarchlinux-br·org>
-# Contributor: xduugu <xduuguΘgmx·com>
-# Contributor: Peter 'piie' Feuerer <peterΘpiie·net>
-# Contributor: Sascha Pfau <MrPeacockΘgmail·com>
-# Contributor: iggy <iggy.mfΘgmail·com>
-
-pkgname="virtualbox_bin"
-pkgver="3.2.6"
-_build="63112"
-pkgrel=1
-pkgdesc="Powerful x86 virtualization (Personal Use Binaries Edition)."
-arch=('i686' 'x86_64')
-url="http://virtualbox.org"
-license=('custom:PUEL')
-depends=('libidl2' 'libxcursor' 'libxinerama' 'libxslt' 'curl' 'gcc' 'make' 'kernel26-headers')
-optdepends=("qt: for VirtualBox GUI"
- "sdl: for VBoxSDL and VirtualBox GUI"
- "libgl: for shared OpenGL"
- "libxt: for shared Clipboard"
- "alsa-lib: for ALSA support"
- "pulseaudio: for PulseAudio support")
-provides=("virtualbox=${pkgver}")
-conflicts=('virtualbox-ose' 'virtualbox-modules')
-install='virtualbox.install'
-_arch='x86'
-[ "$CARCH" = "x86_64" ] && _arch='amd64'
-source=("VirtualBox-${pkgver}-${_build}-Linux_${_arch}.run::http://download.virtualbox.org/virtualbox/${pkgver}/VirtualBox-${pkgver}-${_build}-Linux_${_arch}.run"
- '10-vboxdrv.rules'
- 'vboxdrv')
-md5sums=('a32de974d0e06196e7fd4581d93535b1'
- '98859bfca9ef2ebf2ea43eb9123316fc'
- '160fc08a43cd9a719d306b5f023dea42')
-[ "$CARCH" = "x86_64" ] && md5sums[0]='c88939c097f9e077b3941f5752b9e6d7'
-
-build() {
- # Check and unpack the run package via sh(1)
- sh "VirtualBox-${pkgver}-${_build}-Linux_${_arch}.run" --check || return 1
- echo yes | sh "VirtualBox-${pkgver}-${_build}-Linux_${_arch}.run" --target "$srcdir" \
- --nox11 --noexec &> /dev/null || return 1
-
- # Unpack bundled files
- install -d "$pkgdir/opt/VirtualBox" || return 1
- cd "$pkgdir/opt/VirtualBox"
- tar -xjf "$srcdir/VirtualBox.tar.bz2" || return 1
-
- install -d "$pkgdir/usr/"{bin,share/applications,share/pixmaps} || return 1
-
- # Hardened build: Mark binaries suid root, create symlinks for working around
- # unsupported $ORIGIN/.. in VBoxC.so and make sure the
- # directory is only writable by the user (paranoid).
- chmod 4511 VirtualBox VBox{SDL,Headless,NetDHCP}
- for _lib in VBox{VMM,REM,RT,DDU,XPCOM}.so; do
- ln -sf "/opt/VirtualBox/${_lib}" "components/${_lib}"
- done
- chmod go-w .
-
- # VBoxNetAdpCtl needs to be suid root in any case
- chmod 4511 VBoxNetAdpCtl
-
- # Replace VirtualBox built-in Qt by system Qt libraries (disabled as of
- # 2010-03-26, 3.1.6-1)
- #for _lib in libQt{Core,Gui,Network,OpenGL}; do
- # rm "${_lib}VBox.so.4"
- # ln -s "/usr/lib/${_lib}.so.4" "${_lib}VBox.so.4"
- #done
-
- # Install the SDK (disabled, since the extension expects an UCS4-compiled
- # python, while Arch Linux has an UCS2-compiled python)
- #cd "$pkgdir/opt/VirtualBox/sdk/installer"
- #VBOX_INSTALL_PATH="/opt/VirtualBox" python vboxapisetup.py install --root "${pkgdir}" || return 1
- #rm -Rf build
- #cd "$pkgdir/opt/VirtualBox"
- rm -Rf sdk vboxshell.py VBoxPython*
-
- # Install rc.d script for module compilation
- install -Dm0755 "${srcdir}/vboxdrv" "${pkgdir}/etc/rc.d/vboxdrv" || return 1
-
- # Replace init script stuff
- sed -i -e 's,sudo /etc/init.d/vboxdrv setup,/etc/rc.d/vboxdrv setup,g' \
- "$pkgdir/opt/VirtualBox/VBox.sh"
- sed -i -e 's,sudo /etc/init.d/vboxdrv restart,modprobe vboxdrv,g' \
- "$pkgdir/opt/VirtualBox/VBox.sh"
-
- # Install udev rules
- install -Dm0644 "$srcdir/10-vboxdrv.rules" "$pkgdir/lib/udev/rules.d/10-vboxdrv.rules" || return 1
-
- # Symlink the launchers
- for _bin in VirtualBox VBox{Headless,Manage,SDL,SVC,Tunctl,NetAdpCtl} rdesktop-vrdp; do
- ln -s "/opt/VirtualBox/${_bin}" "$pkgdir/usr/bin/${_bin}"
- done
-
- # Symlink the desktop icon and ".desktop" files
- ln -s "/opt/VirtualBox/VBox.png" "$pkgdir/usr/share/pixmaps/VBox.png"
- ln -s "/opt/VirtualBox/virtualbox.desktop" "$pkgdir/usr/share/applications/VirtualBox.desktop"
-
- # Symlink the license
- install -d "$pkgdir/usr/share/licenses/$pkgname" || return 1
- ln -s "/opt/VirtualBox/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/PUEL"
-
- # Setup configuration
- install -d "$pkgdir/etc/vbox" || return 1
- echo 'INSTALL_DIR="/opt/VirtualBox"' > "$pkgdir/etc/vbox/vbox.cfg"
-}
diff --git a/virtualbox_bin/vbox.install b/virtualbox_bin/vbox.install
deleted file mode 100644
index c4615db..0000000
--- a/virtualbox_bin/vbox.install
+++ /dev/null
@@ -1,102 +0,0 @@
-_install_notes() {
- echo
- echo '---------------------------------------------------------------------------'
- echo ' IMPORTANT NOTES:'
- echo
- echo '- Run "vbox_build_module" as root every time your kernel is upgraded, to'
- echo ' compile the module for the new kernel version.'
- echo '- Add your user to the vboxusers group:'
- echo ' gpasswd -a USERNAME vboxusers'
- echo '- Add "vboxdrv" to the MODULES array in your "/etc/rc.conf"'
- echo '- Add "vboxnetflt" to MODULES if you want Host Interface networking.'
- echo '- Add "vboxnetadp" to MODULES if you want Host-Only networking.'
- echo '- If USB does not work for you out-of-the-box, add the following line'
- echo ' to "/etc/fstab":'
- echo ' none /proc/bus/usb usbfs auto,busgid=108,busmode=0775,devgid=108,devmode=0664 0 0'
- echo "---------------------------------------------------------------------------"
-}
-
-# $1: The new package version
-post_install() {
- # Unload modules (if any).
- for i in vboxdrv vboxnetadp vboxnetflt; do
- modprobe -r $i &>/dev/null
- done
-
- # Build new module
- echo "Building VirtualBox modules..."
- /usr/bin/vbox_build_module &>/dev/null
-
- # Add vboxusers group
- #
- # This GID is reserved (http://wiki.archlinux.org/index.php/UID_and_GID_list)
- # But in some systems it may be being used. Please replace if needed.
- groupadd -f -g 108 vboxusers
-
- # Create the directory below if it doesn't exist
- mkdir -p /var/run/VirtualBox
-
- # Load new udev rule for module vboxdrv
- udevadm control --reload-rules
-
- # Show the license
- echo '---------------------------------------------------------------------------' >&2
- echo ' You must agree to the following license in order to use this program:' >&2
- echo >&2
- cat /opt/VirtualBox/LICENSE >&2
- echo >&2
- echo '---------------------------------------------------------------------------' >&2
-
- # Load the new module
- modprobe vboxdrv
-
- _install_notes
-}
-
-# $1: The new package version
-# $2: The old package version
-post_upgrade() {
- _NEWVERSION=`echo $1 | cut -f-1 -d '-'`
- _OLDVERSION=`echo $2 | cut -f-1 -d '-'`
-
- # Unload modules (if any).
- for i in vboxdrv vboxnetadp vboxnetflt; do
- modprobe -r $i &>/dev/null
- done
-
- # Remove any stuff (eg. module compilation files) from an
- # old installation. Old versions used to use these directories.
- if [ "$_NEWVERSION" != "$_OLDVERSION" ]; then
- rm -Rf "/opt/VirtualBox-${_OLDVERSION}" &>/dev/null
- fi
- if [ "$1" != "$2" ]; then
- rm -Rf "/opt/virtualbox" &>/dev/null
- fi
-
- # Create the directory below if it doesn't exist
- mkdir -p /var/run/VirtualBox
-
- # Build new module
- echo "Building VirtualBox modules..."
- /usr/bin/vbox_build_module &>/dev/null
-
- # Load the new module
- modprobe vboxdrv
-
- _install_notes
-}
-
-# $1: The old package version
-pre_remove() {
- # Unload modules (if any).
- for i in vboxdrv vboxnetadp vboxnetflt; do
- modprobe -r $i &>/dev/null
- done
-
- # Remove the module files.
- rm -f /lib/modules/`uname -r`/misc/{vboxdrv,vboxnetadp,vboxnetflt}.ko
-
- # Remove any stuff remaining from the module compilation.
- rm -Rf "/opt/VirtualBox"
-}
-
diff --git a/virtualbox_bin/vbox_build_module b/virtualbox_bin/vbox_build_module
deleted file mode 100644
index 58e1e6b..0000000
--- a/virtualbox_bin/vbox_build_module
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/bash
-
-echo "Building vboxdrv for `uname -sr`"
-cd "/opt/VirtualBox/src"
-make clean && make && make install
diff --git a/virtualbox_bin/vboxdrv b/virtualbox_bin/vboxdrv
deleted file mode 100644
index df1bfeb..0000000
--- a/virtualbox_bin/vboxdrv
+++ /dev/null
@@ -1,54 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-. /etc/vbox/vbox.cfg
-
-LOG="/var/log/vbox-install.log"
-if [ -n "$INSTALL_DIR" ]; then
- VBOXMANAGE="$INSTALL_DIR/VBoxManage"
- BUILDVBOXDRV="$INSTALL_DIR/src/vboxdrv/build_in_tmp"
- BUILDVBOXNETFLT="$INSTALL_DIR/src/vboxnetflt/build_in_tmp"
- BUILDVBOXNETADP="$INSTALL_DIR/src/vboxnetadp/build_in_tmp"
-else
- echo "missing vbox.cfg"
- exit 0
-fi
-case "$1" in
- setup)
- if find /lib/modules/`uname -r` -name "vboxnetadp\.*" 2>/dev/null|grep -q vboxnetadp; then
- stat_busy "Removing old VirtualBox netadp kernel module"
- find /lib/modules/`uname -r` -name "vboxnetadp\.*" 2>/dev/null|xargs rm -f 2>/dev/null
- stat_done
- fi
- if find /lib/modules/`uname -r` -name "vboxnetflt\.*" 2>/dev/null|grep -q vboxnetflt; then
- stat_busy "Removing old VirtualBox netflt kernel module"
- find /lib/modules/`uname -r` -name "vboxnetflt\.*" 2>/dev/null|xargs rm -f 2>/dev/null
- stat_done
- fi
- if find /lib/modules/`uname -r` -name "vboxdrv\.*" 2>/dev/null|grep -q vboxdrv; then
- stat_busy "Removing old VirtualBox kernel module"
- find /lib/modules/`uname -r` -name "vboxdrv\.*" 2>/dev/null|xargs rm -f 2>/dev/null
- stat_done
- fi
- stat_busy "Recompiling VirtualBox kernel modules"
- if ! $BUILDVBOXDRV \
- --save-module-symvers /tmp/vboxdrv-Module.symvers \
- --no-print-directory install > $LOG 2>&1; then
- echo "Look at $LOG to find out what went wrong"
- fi
- if ! $BUILDVBOXNETFLT \
- --use-module-symvers /tmp/vboxdrv-Module.symvers \
- --no-print-directory install >> $LOG 2>&1; then
- echo "Look at $LOG to find out what went wrong"
- fi
- if ! $BUILDVBOXNETADP \
- --use-module-symvers /tmp/vboxdrv-Module.symvers \
- --no-print-directory install >> $LOG 2>&1; then
- echo "Look at $LOG to find out what went wrong"
- fi
- stat_done
- ;;
- *)
- echo "usage: $0 {setup}"
-esac
diff --git a/virtualbox_bin/virtualbox.install b/virtualbox_bin/virtualbox.install
deleted file mode 100644
index e41a22b..0000000
--- a/virtualbox_bin/virtualbox.install
+++ /dev/null
@@ -1,128 +0,0 @@
-# $1: The new package version
-post_install() {
- # Unload modules (if any)
- for _mod in vbox{drv,netadp,netflt}; do
- modprobe -r $_mod &> /dev/null
- done
-
- # Build new module
- /etc/rc.d/vboxdrv setup
-
- # Add vboxusers group, GID 108 is reserved (http://wiki.archlinux.org/index.php/UID_and_GID_list),
- # but in some systems it may be being used - please replace if needed.
- groupadd -f -g 108 vboxusers
-
- # Create the directory below if it doesn't exist
- mkdir -p "/var/run/VirtualBox"
-
- # Load new udev rule for module vboxdrv
- udevadm control --reload-rules
-
- # Show the license
- echo >&2
- echo '==> You must agree to the following license in order to use this program:' >&2
- echo '------------------------------------------------------------------------' >&2
- echo >&2
- cat "/opt/VirtualBox/LICENSE" >&2
- echo >&2
- echo '------------------------------------------------------------------------' >&2
-
- /bin/cat <<EOF
-
-==> Add your user to the vboxusers group:
-==> # gpasswd -a USERNAME vboxusers
-==>
-==> You must load vboxdrv module before starting VirtualBox:
-==> # modprobe vboxdrv
-==>
-==> You must load vboxnetflt for Host Interface Networking:
-==> # modprobe vboxnetflt
-==>
-==> You must load vboxnetadp for Host-Only networking:
-==> # modprobe vboxnetadp
-==>
-==> To load it automatically, add vboxdrv module to the "MODULES" array
-==> "/etc/rc.conf".
-==>
-==> Run \`/etc/rc.d/vboxdrv setup\` as root every time your kernel is
-==> upgraded, to compile the module for the new kernel version.
-==>
-==> If USB does not work for you out-of-the-box, add the following line
-==> to "/etc/fstab":
-==> "none /proc/bus/usb usbfs auto,busgid=108,busmode=0775,devgid=108,devmode=0664 0 0"
-
-EOF
-}
-
-# $1: The new package version
-# $2: The old package version
-post_upgrade() {
- _NEWVERSION=`echo $1 | cut -f-1 -d '-'`
- _OLDVERSION=`echo $2 | cut -f-1 -d '-'`
-
- # Unload modules (if any)
- for _mod in vbox{drv,netadp,netflt}; do
- modprobe -r $_mod &> /dev/null
- done
-
- # Remove any stuff (e.g. module compilation files) from an old installation - old versions used
- # to use these directories.
- if [ "$_NEWVERSION" != "$_OLDVERSION" ]; then
- rm -Rf "/opt/VirtualBox-${_OLDVERSION}" &> /dev/null
- fi
- if [ "$1" != "$2" ]; then
- rm -Rf "/opt/virtualbox" &> /dev/null
- fi
-
- # Build new module
- /etc/rc.d/vboxdrv setup
-
- # Create the directory below if it doesn't exist
- mkdir -p "/var/run/VirtualBox"
-
- /bin/cat <<EOF
-
-==> You must load vboxdrv module before starting VirtualBox:
-==> # modprobe vboxdrv
-==>
-==> You must load vboxnetflt for Host Interface Networking:
-==> # modprobe vboxnetflt
-==>
-==> You must load vboxnetadp for Host-Only networking:
-==> # modprobe vboxnetadp
-==>
-==> To load it automatically, add vboxdrv module to the "MODULES" array
-==> "/etc/rc.conf".
-==>
-==> Run \`/etc/rc.d/vboxdrv setup\` as root every time your kernel is
-==> upgraded, to compile the module for the new kernel version.
-==>
-==> If USB does not work for you out-of-the-box, add the following line
-==> to "/etc/fstab":
-==> "none /proc/bus/usb usbfs auto,busgid=108,busmode=0775,devgid=108,devmode=0664 0 0"
-
-EOF
-
- if [ "`vercmp $_OLDVERSION 3.2.2`" -lt 0 ]; then
- /bin/cat <<EOF
-==> IMPORTANT: This package now uses \`/etc/rc.d/vboxdrv setup\` instead
-==> of the old "vbox_build_module" script.
-
-EOF
- fi
-}
-
-# $1: The old package version
-pre_remove() {
- # Unload modules (if any)
- for _mod in vbox{drv,netadp,netflt}; do
- modprobe -r $_mod &> /dev/null
- done
-
- # Remove the module files
- rm -f "/lib/modules/`uname -r`/misc/"{vboxdrv,vboxnetadp,vboxnetflt}.ko
-
- # Remove any stuff remaining from the module compilation
- rm -Rf "/opt/VirtualBox"
-}
-