summaryrefslogtreecommitdiffstats
path: root/weechat-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'weechat-git/PKGBUILD')
-rw-r--r--weechat-git/PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/weechat-git/PKGBUILD b/weechat-git/PKGBUILD
index 6c18c93..2f94f79 100644
--- a/weechat-git/PKGBUILD
+++ b/weechat-git/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Tim Zebulla <amon at faumrahrer dot de>
pkgname=weechat-git
-pkgver=20091022
+pkgver=20100107
pkgrel=1
pkgdesc="Fast, light & extensible IRC client (curses UI)"
arch=('i686' 'x86_64')
@@ -13,7 +13,8 @@ makedepends=('git' 'cmake')
optdepends=('tcl: tcl scripting support'
'perl>=5.10: perl scripting support'
'python>=2.6: python scripting support'
- 'lua: lua scripting support')
+ 'lua: lua scripting support'
+ 'ruby: ruby scripting support')
provides=('weechat')
conflicts=('weechat')
options=(!strip)
@@ -41,9 +42,9 @@ build() {
git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
cd "$srcdir/$_gitname-build"
- cmake -DCMAKE_BUILD_TYPE=Debug -DDISABLE_RUBY=ON -DDISABLE_DOC=ON -DPREFIX=/usr || return 1
+ cmake -DCMAKE_BUILD_TYPE=Debug -DDISABLE_DOC=ON -DPREFIX=/usr || return 1
make DESTDIR="$pkgdir/" install
}
-# note - to disable an option, use -DDISABLE_JABBER=ON
-# this should change soon, and will be -DENABLE_JABBER=OFF
+# note - to disable an option, use -DDISABLE_RUBY=ON
+# this should change soon, and will be -DENABLE_RUBY=OFF
# also, you can see the configure options with ccmake, then just -DOPTIONHERE=ON/OFF