summaryrefslogtreecommitdiffstats
path: root/weechat-git/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'weechat-git/PKGBUILD')
-rw-r--r--weechat-git/PKGBUILD50
1 files changed, 0 insertions, 50 deletions
diff --git a/weechat-git/PKGBUILD b/weechat-git/PKGBUILD
deleted file mode 100644
index dc724fa..0000000
--- a/weechat-git/PKGBUILD
+++ /dev/null
@@ -1,50 +0,0 @@
-# Maintainer: Licia Todd <tigrmesh at aol dot com>
-# Contributor: Tim Zebulla <amon at faumrahrer dot de>
-
-pkgname=weechat-git
-pkgver=20100804
-pkgrel=1
-pkgdesc="Fast, light & extensible IRC client (curses UI)"
-arch=('i686' 'x86_64')
-url="http://weechat.flashtux.org"
-license=('GPL3')
-depends=('aspell' 'iksemel')
-makedepends=('git' 'cmake')
-optdepends=('tcl: tcl scripting support'
- 'perl>=5.10: perl scripting support'
- 'python>=2.6: python scripting support'
- 'lua: lua scripting support'
- 'ruby: ruby scripting support')
-provides=('weechat')
-conflicts=('weechat')
-options=(!strip)
-install=weechatgit.install
-
-_gitroot="git://git.sv.gnu.org/weechat.git"
-_gitname="weechat"
-
-build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [ -d $_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- msg "First time connected - cloning repo, this may take a while..."
- git clone $_gitroot
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting cmake..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
-
- cmake -DCMAKE_BUILD_TYPE=Debug -DDISABLE_DOC=ON -DPREFIX=/usr || return 1
- make DESTDIR="$pkgdir/" install
-}
-# note - to disable an option, use -DDISABLE_RUBY=ON
-# this should change soon, and will be -DENABLE_RUBY=OFF
-# also, you can see the configure options with ccmake, then just -DOPTIONHERE=ON/OFF