summaryrefslogtreecommitdiffstats
path: root/wireshark
diff options
context:
space:
mode:
Diffstat (limited to 'wireshark')
-rw-r--r--wireshark/PKGBUILD29
-rw-r--r--wireshark/wireshark.desktop10
-rw-r--r--wireshark/wireshark.pngbin0 -> 18535 bytes
3 files changed, 39 insertions, 0 deletions
diff --git a/wireshark/PKGBUILD b/wireshark/PKGBUILD
new file mode 100644
index 0000000..56ac8b7
--- /dev/null
+++ b/wireshark/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id$
+# Maintainer: Hugo Doria <hugo@archlinux.org>
+
+pkgname=wireshark
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="A free network protocol analyzer for Unix/Linux and Windows"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('gtk2>=2.14.5' 'heimdal>=1.2.1' 'libpcap>=1.0.0' 'bash' 'gnutls>=2.4.1' 'libcap>=2.16')
+makedepends=('bison' 'flex')
+url="http://www.wireshark.org/"
+replaces=('ethereal')
+options=(!libtool)
+source=(http://www.wireshark.org/download/src/${pkgname}-${pkgver}.tar.gz wireshark.desktop wireshark.png)
+md5sums=('56d760eeec0001b9a0b816ace3e99e44'
+ '504ede44c02b2a52f6cbd3bffdf93b8d'
+ 'e771800a8c977fe223583a453bc27397')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ export CFLAGS="-fno-unit-at-a-time ${CFLAGS}"
+ ./configure --prefix=/usr --with-ssl || return 1
+ make all || return 1
+ make DESTDIR=${pkgdir} install || return 1
+
+ install -Dm644 ${srcdir}/wireshark.png ${pkgdir}/usr/share/icons/wireshark.png
+ install -Dm644 ${srcdir}/wireshark.desktop ${pkgdir}/usr/share/applications/wireshark.desktop
+}
diff --git a/wireshark/wireshark.desktop b/wireshark/wireshark.desktop
new file mode 100644
index 0000000..f4317f6
--- /dev/null
+++ b/wireshark/wireshark.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+GenericName=Wireshark
+Comment=Network protocol analyzer
+Name=wireshark
+Exec=wireshark
+Icon=/usr/share/icons/wireshark.png
+Type=Application
+Terminal=false
+Categories=Application;Network;
diff --git a/wireshark/wireshark.png b/wireshark/wireshark.png
new file mode 100644
index 0000000..4e40263
--- /dev/null
+++ b/wireshark/wireshark.png
Binary files differ