summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorcanyonknight <canyonknight@gmail.com>2012-10-29 02:04:32 +0100
committerLukas Fleischer <archlinux@cryptocrack.de>2012-10-29 12:28:45 +0100
commit9fd4845d16e41bf88535f77f627202f25b6d2112 (patch)
tree7e04e44a85e2cc3cf1192df0f0b78f77208754e4
parent985a2ed49cc49f1e3be8a3699be8e1fa9c8705f4 (diff)
downloadaur-9fd4845d16e41bf88535f77f627202f25b6d2112.tar.gz
aur-9fd4845d16e41bf88535f77f627202f25b6d2112.tar.xz
pkgsubmit.php: Check that there is one directory in a tarball
Users are able to upload tarballs without a directory. The directory count for a tarball is available, so use it to display an error when there is not a single directory. This patch has no effect on users who generate their uploaded tarballs using makepkg. All other users must include a directory in their tarball. Signed-off-by: canyonknight <canyonknight@gmail.com> Signed-off-by: Lukas Fleischer <archlinux@cryptocrack.de>
-rw-r--r--web/html/pkgsubmit.php4
1 files changed, 4 insertions, 0 deletions
diff --git a/web/html/pkgsubmit.php b/web/html/pkgsubmit.php
index efd90e13..885c44fd 100644
--- a/web/html/pkgsubmit.php
+++ b/web/html/pkgsubmit.php
@@ -106,6 +106,10 @@ if ($uid):
}
}
+ if (!$error && $dircount !== 1) {
+ $error = __("Error - source tarball may not contain files outside a directory.");
+ }
+
if (!$error && empty($pkgbuild_raw)) {
$error = __("Error trying to unpack upload - PKGBUILD does not exist.");
}