summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Fleischer <archlinux@cryptocrack.de>2011-08-22 08:35:18 +0200
committerLukas Fleischer <archlinux@cryptocrack.de>2011-08-22 08:35:18 +0200
commite411ef1d809a98d14b494afdfc47b07962770684 (patch)
treeb80da096f59b97ebff5bfcd63caeaa187739a596
parent114edd9ff82b3860e2ca4b68589d661ec6d5fe39 (diff)
parent53a31865f41db7315dc5c99e1b100f397ef80b1a (diff)
downloadaur-e411ef1d809a98d14b494afdfc47b07962770684.tar.gz
aur-e411ef1d809a98d14b494afdfc47b07962770684.tar.xz
Merge branch 'maint'
-rw-r--r--UPGRADING4
-rw-r--r--web/lib/aurjson.class.php2
-rw-r--r--web/template/pkg_details.php6
3 files changed, 6 insertions, 6 deletions
diff --git a/UPGRADING b/UPGRADING
index dad4adff..c0866e5e 100644
--- a/UPGRADING
+++ b/UPGRADING
@@ -28,13 +28,13 @@ container or optionally create a ".htaccess" file in the upload directory):
----
RewriteEngine on
-RewriteRule ^/packages/([^/]{1,2})([^/]*/(PKGBUILD|.*\.tar\.gz|))$ /packages/$1/$1$2
+RewriteRule ^/packages/([^/]{1,2})([^/]*/(PKGBUILD|[^/]*\.tar\.gz|))$ /packages/$1/$1$2
----
The following equivalent rule can be used for lighttpd setups:
----
-url.rewrite-once = ( "^/packages/([^/]{1,2})([^/]*/(PKGBUILD|.*\.tar\.gz|))$" => "/packages/$1/$1$2" )
+url.rewrite-once = ( "^/packages/([^/]{1,2})([^/]*/(PKGBUILD|[^/]*\.tar\.gz|))$" => "/packages/$1/$1$2" )
----
If you use a non-standard URL_DIR, slight modifications might be necessary.
diff --git a/web/lib/aurjson.class.php b/web/lib/aurjson.class.php
index 277c824e..b5963595 100644
--- a/web/lib/aurjson.class.php
+++ b/web/lib/aurjson.class.php
@@ -203,7 +203,7 @@ class AurJSON {
// just using sprintf to coerce the pqd to an int
// should handle sql injection issues, since sprintf will
// bork if not an int, or convert the string to a number 0
- $where_condition = "ID={$pqdata}";
+ $where_condition = "Packages.ID={$pqdata}";
}
else {
$where_condition = sprintf("Name=\"%s\"",
diff --git a/web/template/pkg_details.php b/web/template/pkg_details.php
index c03493d8..880a6758 100644
--- a/web/template/pkg_details.php
+++ b/web/template/pkg_details.php
@@ -10,7 +10,7 @@ if ($uid == $row["MaintainerUID"] or
$edit_cat = "<form method='post' action='packages.php?ID=".$pkgid."'>\n";
$edit_cat.= "<p>";
$edit_cat.= "<input type='hidden' name='action' value='do_ChangeCategory' />";
- $edit_cat.= "<span class='f3'>Category:</span> ";
+ $edit_cat.= "<span class='f3'>" . __("Category") . ":</span> ";
$edit_cat.= "<select name='category_id'>\n";
foreach ($catarr as $cid => $catname) {
$edit_cat.= "<option value='$cid'";
@@ -19,13 +19,13 @@ if ($uid == $row["MaintainerUID"] or
}
$edit_cat.=">".$catname."</option>";
}
- $edit_cat.= "</select>&nbsp;<input type='submit' value='Change category' />";
+ $edit_cat.= "</select>&nbsp;<input type='submit' value='" . __("Change category") . "' />";
$edit_cat.= "</p>";
$edit_cat.= "</form>";
}
else {
- $edit_cat = "<span class='f3'>Category: " . $row['Category'] . "</span>";
+ $edit_cat = "<span class='f3'>" . __("Category") . ": " . $row['Category'] . "</span>";
}
if ($row["SubmitterUID"]) {